Viewer 1.2.1.7 frequently disconnects

Viewer 1.2.1.7 frequently disconnects

Postby RodolfoGiovanninetti » 2018-02-20 08:34

I have found this problem with the viewer "1.2.1.7".
I connect to a pc, that has server "1.2.1.6" or "1.2.1.7", and the viewer disconnects frequently.
It automatically reconnects, but this issue is so frequent that I had to go back to "1.2.1.6".


Thank You and regards

Rodolfo Giovanninetti
RodolfoGiovanninetti
8
8
 
Posts: 10
Joined: 2012-10-09 12:57

Re: Viewer 1.2.1.7 frequently disconnects

Postby kissson » 2018-02-22 07:23

same here, I use 1.2.1.7 server and client on win10x64 to make reverse connection
it disconnects so frequently, I have 4 pcs running server(3 w10x64 1 w7x64) and one viewer(w10x64) listening, all have same problem, now turn all back to 1.2.1.6
kissson
8
8
 
Posts: 28
Joined: 2006-06-12 08:52

Re: Viewer 1.2.1.7 frequently disconnects

Postby CPC » 2018-02-26 22:22

I'm having an similar issue.

However, I cant say for certain its viewer 1.2.1.7 or if I have an abnormally high amount of clients with poor wifi connections since changing from viewer 1.2.1.6 to 1.2.1.7. It reconnects and I work through it, but I seem to be getting more machines disconnecting/reconnecting with some staying on for less then and minute and reconnecting again over and over. I have had this in the past somewhat but usually could tell it was a bad wifi connection at the server end and less frequent than currently. I've tried to watch for a pattern and it seems to be mostly with people on wifi vs Ethernet in my case. Maybe 1.2.1.7 viewer less stable connections or this could be coincidental since moving to 1.2.1.7 viewer in my case. I have not tested going back to 1.2.1.6 to see if it helps. On most days around 70% of the connections are stable and without issue.
CPC
8
8
 
Posts: 14
Joined: 2010-10-08 15:31

Re: Viewer 1.2.1.7 frequently disconnects

Postby burzek » 2018-03-09 11:30

Hi,

I also have the same problem.
Trying to connect from w10 x64 uvnc 1.2.1.7 to w7 x64 uvnc 1.2.1.6, the connection sometimes stable goes for 7-8 minutes without any problems.
Sometimes, after 30 seconds , it disconnects and connects 1-2 times.
Never that such a problem with 1.2.1.6 , why it keeps disconnecting?

Cheers,
Burzek
burzek
8
8
 
Posts: 14
Joined: 2006-06-01 15:51

Re: Viewer 1.2.1.7 frequently disconnects

Postby endmarsfr » 2018-03-09 17:37

Hello,

Same issue using W10 x64 home and Win7 x64 home (as server of course)
client is always win10 x64.

previous version 1.2.1.6 was working good :(

regards
endmarsfr
 
Posts: 1
Joined: 2018-03-09 17:32

Re: Viewer 1.2.1.7 frequently disconnects

Postby Rudi De Vos » 2018-03-11 17:11

I'm trying to compare 1.2.17 and 1.2.16 srccode as i can't repeat it on my testpc's.

Did someone tried 1.2.16 viewer with the 1.2.17 server and invers.
It would already be a lot of help if we could pinpoint it to server 17 or viewer 17

Major difference i can see
*30s timeout was added ( viewer/server niet to communicate at least once in 30s)
*server send a keepalive as answer to a viewer keepalive ( possible this interact with normal updates and could lead to broken updates)
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5790
Joined: 2004-04-23 10:21

Re: Viewer 1.2.1.7 frequently disconnects

Postby Rudi De Vos » 2018-03-11 20:27

Using a network simulator...to add lag, latency limited bandwidth

Viewer 1215 with server 1217 seems to be ok.
viewer 1216 also seems ok.

Zrle encoder become unstable on "broken networks", Tight encoder keeps working.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5790
Joined: 2004-04-23 10:21

Re: Viewer 1.2.1.7 frequently disconnects

Postby opeongo » 2018-03-15 13:45

I just wanted to chime in here that I am noticing this issue as well.

The 1.2.1.7 viewer on window 7 pro 64 has frequent disconnects from servers on the lan. The lan is not busy. The previous version of the viewer did not have this problem.

I will roll back to 1.2.1.6 for now. Otherwise uvnc is a great software!
opeongo
 
Posts: 2
Joined: 2018-03-15 13:39

Re: Viewer 1.2.1.7 frequently disconnects

Postby Rudi De Vos » 2018-03-15 19:06

If possible, try to test the 1.2.2.0 ( forum version).
If it behave better then the latest update
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5790
Joined: 2004-04-23 10:21

Re: Viewer 1.2.1.7 frequently disconnects

Postby RodolfoGiovanninetti » 2018-03-15 19:10

[quote="Rudi De Vos"]If possible, try to test the 1.2.2.0 ( forum version).
If it behave better then the latest update[/quote]
Where can I find it?


Thank You and regards

Rodolfo Giovanninetti
RodolfoGiovanninetti
8
8
 
Posts: 10
Joined: 2012-10-09 12:57


Re: Viewer 1.2.1.7 frequently disconnects

Postby CPC » 2018-03-16 22:17

For me... It seems the vncviewer 1.2.1.7 was the issue.

When I replace only vncviewer.exe 1.2.1.7 with 1.2.2.0 (3/14/2018 23:02:28) the frequent disconnect issue seems to be resolved.

On viewer 1.2.1.7, I was getting consistent disconnects about every 30-60 seconds on several machines today. I left the servers running with auto reconnect on. I closed vncviewer 1.2.1.7 and replaced it with 1.2.2.0 . Opening vncviewer 1.2.2.0 with the same settings, the 1.2.1.7 servers that I left running, all reconnected to me and have not had any disconnects in several days.

Much more pleasant to use. :D


Thanks Rudi
CPC
CPC
8
8
 
Posts: 14
Joined: 2010-10-08 15:31

Re: Viewer 1.2.1.7 frequently disconnects

Postby AnotherUVNCuser » 2018-03-21 00:33

CPC wrote:For me... It seems the vncviewer 1.2.1.7 was the issue.

When I replace only vncviewer.exe 1.2.1.7 with 1.2.2.0 (3/14/2018 23:02:28) the frequent disconnect issue seems to be resolved.
Good to know!

@ Rudi: I haven't visited this place for a while but i really appreciate (and respect) it that you're still looking out for your users 8) :thumbs:
Last edited by AnotherUVNCuser on 2018-03-29 01:35, edited 1 time in total.
AnotherUVNCuser
20
20
 
Posts: 52
Joined: 2017-09-13 00:40

Re: Viewer 1.2.1.7 frequently disconnects

Postby opeongo » 2018-03-27 16:50

Rudi De Vos wrote:If possible, try to test the 1.2.2.0 ( forum version).
If it behave better then the latest update


I tried with the 1.2.2.0 version that I downloaded on March 16.

This version resolved the problem with the vncviewer frequent disconnects. However, the server with this version did not do updates correctly and was unusable. My solution was to reinstall 1.2.1.6 and then add the new vncviewer.exe. This combination works solidly.

One minor point about the vncviewer (not a showstopper for me). I have a two monitor setup on my server, and a single monitor on my viewer. The viewer seems to have a mode where it will start with the display on the first (left) monitor, and as the mouse is moved to the right edge of the screen it will automatically 'pan' the screen image to the left. However, the replacement image coming in from the right side is just grey, and is not the image from the second (right) monitor. I don't know if this is expected behaviour, but the grey does not provide any useful information.

Toggling between monitors using the 'Select Full Desktop / Switch monitor(driver only)' button works very nicely.
opeongo
 
Posts: 2
Joined: 2018-03-15 13:39

Re: Viewer 1.2.1.7 frequently disconnects

Postby AnotherUVNCuser » 2018-04-06 21:37

CPC wrote:For me... It seems the vncviewer 1.2.1.7 was the issue.

When I replace only vncviewer.exe 1.2.1.7 with 1.2.2.0 (3/14/2018 23:02:28) the frequent disconnect issue seems to be resolved.

On viewer 1.2.1.7, I was getting consistent disconnects about every 30-60 seconds on several machines today. I left the servers running with auto reconnect on. I closed vncviewer 1.2.1.7 and replaced it with 1.2.2.0 . Opening vncviewer 1.2.2.0 with the same settings, the 1.2.1.7 servers that I left running, all reconnected to me and have not had any disconnects in several days.

Much more pleasant to use. :D


Thanks Rudi
CPC


What can you say about server 1.2.2.0 with viewer 1.2.2.0 (or older)?
AnotherUVNCuser
20
20
 
Posts: 52
Joined: 2017-09-13 00:40

Re: Viewer 1.2.1.7 frequently disconnects

Postby uvncuser33 » 2018-05-12 03:17

Hi, wanted to chime in as im a longtime user of uVNC (as in 8+ years), i have alot of machines running uVNC server of various versions (50+ machines at many different locations, some with latest 1.2.1.7 server also). Alot of these machines are accessed via VPNs some are direct. After 1.2.1.7 upgrade on my viewer side, i was constantly getting disconnects (sometimes a few sec after inital connection).

After upgrading my viewer to this beta 1.2.2.0 version, the disconnect issues are GONE!
Prior i was using viewer 1.2.1.2 (again, connecting to uVNC servers of many various versions) and i never had disconnect issues (unless there was a clear network issue).

Thanks so much for your active work on uVNC, it really is a great tool. I always click your site banners when installing to new PCs, and now will start sending donations as well.
uvncuser33
 
Posts: 1
Joined: 2018-05-12 03:06


Return to 1.2.1.x

Who is online

Users browsing this forum: No registered users and 1 guest

cron