Problem with repeater

Problem with repeater

Postby Guindillas » 2018-11-08 18:55

Hi all !!

Sorry for my bad english. I hope you understand me. Thanks in advance.

I have a problem with the use of the repeater from some machines at some moments. The servers connect directly to the repeater by adding to the file ultravnc.ini in the admin section the line:

service_commandline=-autoreconnect ID:0002 -connect m.y.i.p:5500

All PCs connect to the repeater at startup, but at a certain time, some of them (with Windows 10 Pro 64) stop reaching the repeater signal. If I connect directly and locally within the LAN I can connect, that is, the service is up and running, but it does not signal out to the repeater.
I thought that it would be a problem of permissions in the Firewall, but apparently everything is correct, in addition if it were not like that, it would not connect either with the repeater in the boot.

Finally, if I manually turn the service off and on (net stop uvnc_service - net start uvnc_service) on the server, everything will work correctly again. All signals reach the repeater until after a while (several hours) it fails again.

Is it possible that some other program interferes with the service and prevents its self-connection?
Has anyone seen a similar problem?

Thanks.
Guindillas
 
Posts: 5
Joined: 2018-10-24 17:51

Re: Problem with repeater

Postby Rudi De Vos » 2018-11-08 21:34

More info needed
Version or date repeater and vnc server ?
ultravnc.ini ( erase passwd hash and ip)
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5766
Joined: 2004-04-23 10:21

Re: Problem with repeater

Postby Guindillas » 2018-11-09 09:30

Versions:

UltraVNC Repeater 2016 build 1400
UltraVNC Server 1.2.2.1 Build: Jun 14 2018 22:01:12

UltraVNC.ini
------------------------------------
[ultravnc]
passwd=
passwd2=
[admin]
service_commandline=-autoreconnect ID:0001 -connect nnn.nnn.nnn.nnn:5500
DSMPluginConfig=SecureVNC;0;0x00104001;
UseRegistry=0
MSLogonRequired=0
NewMSLogon=0
DebugMode=0
Avilog=0
path=C:\Program Files\uvnc bvba\UltraVNC
accept_reject_mesg=
DebugLevel=0
DisableTrayIcon=0
rdpmode=0
LoopbackOnly=0
UseDSMPlugin=1
AllowLoopback=1
AuthRequired=1
ConnectPriority=0
DSMPlugin=SecureVNCPlugin64.dsm
AuthHosts=
AllowShutdown=1
AllowProperties=1
AllowEditClients=1
FileTransferEnabled=1
FTUserImpersonation=1
BlankMonitorEnabled=1
BlankInputsOnly=0
DefaultScale=1
primary=1
secondary=0
SocketConnect=1
HTTPConnect=1
AutoPortSelect=1
PortNumber=5900
HTTPPortNumber=5800
IdleTimeout=0
IdleInputTimeout=0
RemoveWallpaper=0
RemoveAero=0
QuerySetting=2
QueryTimeout=10
QueryAccept=0
QueryIfNoLogon=1
InputsEnabled=1
LockSetting=0
LocalInputsDisabled=0
EnableJapInput=0
kickrdp=0
clearconsole=0
[admin_auth]
group1=
group2=
group3=
locdom1=0
locdom2=0
locdom3=0
[poll]
TurboMode=1
PollUnderCursor=0
PollForeground=0
PollFullScreen=1
OnlyPollConsole=0
OnlyPollOnEvent=0
MaxCpu=40
EnableDriver=0
EnableHook=1
EnableVirtual=0
SingleWindow=0
SingleWindowName=
Guindillas
 
Posts: 5
Joined: 2018-10-24 17:51

Re: Problem with repeater

Postby Rudi De Vos » 2018-11-11 13:50

Repeater 1400 has a keepalive feature to avoid network timeouts.

Via webgui
http://localhost:xx/settings.html

UltraVNC Repeater Settings
Keepalive require winvnc >=1201 : [v] <<<<<<<<<<<<<<<<<<<<< (default == off)

If the keepalive is selected the repeater send a keepalive message to the waiting winvnc.exe .
Min version winvnc 1201 and not backward compatiable.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5766
Joined: 2004-04-23 10:21

Re: Problem with repeater

Postby Guindillas » 2018-11-13 13:49

Hi:

Keepalive is on now, but nothing changes. I think I intuit where the problem may come from.

There are 2 remote PCs (A and B) that are turned on 24x7 and another 3 (C,D and E) that turned off every day. The repeater is not active 24x7 but it turns on when I want to connect remotely to the servers.

If the PCs C, D and E start the service with the repeater off, and later (hours) the repeater is turned on, it does not receive signal from the PCs. If then from the PCs we stop and start the service (with the repeater on) then it arrives signal. That is, after a while without the server connecting to the repeater, (because it is off) when it is turned on, it does not receive a signal and it is necessary to stop and start the service on the PC to connect.

But with PCs A and B, that does not happen. If these already connected with the repeater, even if i turn off the repeater for hours, when i restart it, they connect perfectly without stopping and starting the service.

That is, if the server (A and B 24x7) has connected to the repeater, even if the repeater is turned off, when the repeater is turned on again, the repeater receives a signal from the server, but if the server is turned off (C,D y F) and turned on without connection to the repeater, then the connection will never occurs until the service is reactivated.

I hope to have explained myself despite my terrible English.

Thanks.
Guindillas
 
Posts: 5
Joined: 2018-10-24 17:51

Re: Problem with repeater

Postby Rudi De Vos » 2018-11-13 19:08

The keealive wil natural not work when no repeater is running...
I never tested a running server with a repeater that comes alive after a few hours :(
Will test it.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5766
Joined: 2004-04-23 10:21

Re: Problem with repeater

Postby Rudi De Vos » 2018-11-13 22:22

When you activate logging you should see something like this, this keeps running for hours.
Can you verify what happen on your site.

Code: Select all
c:\users\rudi\desktop\ultravnc_291018\winvnc\winvnc\vncserver.cpp : Attempting AutoReconnect....
--Invalid window handle.
c:\users\rudi\desktop\ultravnc_291018\winvnc\winvnc\vsocket.cpp : VSocket() m_pDSMPlugin = NULL
c:\users\rudi\desktop\ultravnc_291018\winvnc\winvnc\vsocket.cpp : closing socket
Tue Nov 13 23:15:50 2018
c:\users\rudi\desktop\ultravnc_291018\winvnc\winvnc\vsocket.cpp : closing socket
--A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
Tue Nov 13 23:16:20 2018
c:\users\rudi\desktop\ultravnc_291018\winvnc\winvnc\vncserver.cpp : Attempting AutoReconnect....
--Invalid window handle.
c:\users\rudi\desktop\ultravnc_291018\winvnc\winvnc\vsocket.cpp : VSocket() m_pDSMPlugin = NULL
c:\users\rudi\desktop\ultravnc_291018\winvnc\winvnc\vsocket.cpp : closing socket
Tue Nov 13 23:16:41 2018
c:\users\rudi\desktop\ultravnc_291018\winvnc\winvnc\vsocket.cpp : closing socket
--A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
Tue Nov 13 23:17:11 2018
c:\users\rudi\desktop\ultravnc_291018\winvnc\winvnc\vncserver.cpp : Attempting AutoReconnect....
--Invalid window handle.
c:\users\rudi\desktop\ultravnc_291018\winvnc\winvnc\vsocket.cpp : VSocket() m_pDSMPlugin = NULL
c:\users\rudi\desktop\ultravnc_291018\winvnc\winvnc\vsocket.cpp : closing socket
Tue Nov 13 23:17:32 2018
c:\users\rudi\desktop\ultravnc_291018\winvnc\winvnc\vsocket.cpp : closing socket
--A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5766
Joined: 2004-04-23 10:21

Re: Problem with repeater

Postby Guindillas » 2018-11-14 13:11

Hello:

The server start up at 05:40
The repeater start up at 12:40 and did not receive a signal from the server.
At 13:37 stop and start service on server manually and the repeater received signal.

This is WinVNC.log file:

Code: Select all
Wed Nov 14 05:40:48 2018
vncserver.cpp : authhosts set to ""
vncproperties.cpp : ***** DBG - Load User Preferences
vncproperties.cpp : clearing user settings
c:\users\rudi\desktop\ultravnc\winvnc\winvnc\vncpasswd.h : PASSWD : FromClear called
vsocket.cpp : VSocket() m_pDSMPlugin = NULL
vncserver.cpp : trying port number 5900
vsocket.cpp : VSocket() m_pDSMPlugin = NULL
Wed Nov 14 05:40:49 2018
vsocket.cpp : closing socket
vsocket.cpp : VSocket() m_pDSMPlugin = NULL
vncsockconnect.cpp : started socket connection thread
vncproperties.cpp : $$$$$$$$$$ ApplyUserPrefs - Plugin Enabled - Call SetDSMPlugin()
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Entry
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Enabled
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Plugin NOT loaded - Try to load it
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Plugin successfully loaded
vnchttpconnect.cpp : started HTTP server thread
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Init plugin call
--El sistema no puede encontrar el archivo especificado.
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - SetPluginParams call
vncserver.cpp : DSMPlugin Params OK
c:\users\rudi\desktop\ultravnc\winvnc\winvnc\vncpasswd.h : PASSWD : ToText called
winvnc.cpp : PostAddNewClient IIIII
vncserver.cpp : AutoConnectRetry(): started
Wed Nov 14 05:40:50 2018
vncserver.cpp : Attempting AutoReconnect....
--El identificador de la ventana no es válido.
vsocket.cpp : VSocket() m_pDSMPlugin = NULL
Wed Nov 14 05:41:11 2018
vsocket.cpp : closing socket
--Se produjo un error durante el intento de conexión ya que la parte conectada no respondió adecuadamente tras un periodo de tiempo, o bien se produjo un error en la conexión establecida ya que el host conectado no ha podido responder.
Wed Nov 14 05:41:20 2018
vncmenu.cpp : user name has changed
--El sistema no puede encontrar el archivo especificado.
vncmenu.cpp : ############## Kill vncMenu thread
vncmenu.cpp : vncmenu killed
winvnc.cpp : ################## Closing Imp Thread
winvnc.cpp : OpenInputdesktop OK
winvnc.cpp : SelectHDESK to Default (340) from d4
winvnc.cpp : Username SYSTEM
vncmenu.cpp : vncmenu(server)
vncserver.cpp : authhosts set to ""
vncproperties.cpp : ***** DBG - Load User Preferences
vncproperties.cpp : clearing user settings
c:\users\rudi\desktop\ultravnc\winvnc\winvnc\vncpasswd.h : PASSWD : FromClear called
vncproperties.cpp : $$$$$$$$$$ ApplyUserPrefs - Plugin Enabled - Call SetDSMPlugin()
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Entry
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Enabled
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Is Loaded
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - New one - Unload the current
Wed Nov 14 05:41:21 2018
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Plugin NOT loaded - Try to load it
--Esta clase no existe.
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Plugin successfully loaded
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Init plugin call
--El sistema no puede encontrar el archivo especificado.
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - SetPluginParams call
vncserver.cpp : DSMPlugin Params OK
c:\users\rudi\desktop\ultravnc\winvnc\winvnc\vncpasswd.h : PASSWD : ToText called
vncmenu.cpp : IsIconSet
Wed Nov 14 13:37:10 2018
winvnc.cpp : ****************** WaitForSingleObject - Shutdown server
vncmenu.cpp : vncMenu::Shutdown: Close menu - Disconnect all - Shutdown server
--El sistema no puede encontrar el archivo especificado.
vncmenu.cpp : vncMenu WM_CLOSE call - All cleanup done
Wed Nov 14 13:37:12 2018
vncmenu.cpp : quitting from WM_DESTROY
vncserver.cpp : KillAuthClients() done
--El identificador de la ventana no es válido.
vncmenu.cpp : vncmenu killed
winvnc.cpp : ################## Closing Imp Thread
winvnc.cpp : ################## SHUTING DOWN SERVER ####################
--Se intentó liberar una exclusión mutua que no pertenece al proceso.
vncserver.cpp : shutting down server object1
vsocket.cpp : shutdown socket
vsocket.cpp : closing socket
--No se permitió una solicitud para enviar o recibir datos ya que el socket no está conectado y no se ha proporcionado ninguna dirección, al realizar el envío en un socket de datagramas por medio de una llamada sendto.
vsocket.cpp : VSocket() m_pDSMPlugin = NULL
vncsockconnect.cpp : quitting socket connection thread
--Una operación de bloqueo fue interrumpida por una llamada a WSACancelBlockingCall.
Wed Nov 14 13:37:14 2018
vsocket.cpp : closing socket
--No se puede establecer una conexión ya que el equipo de destino denegó expresamente dicha conexión.
vsocket.cpp : shutdown socket
vsocket.cpp : VSocket() m_pDSMPlugin = NULL
--No se permitió una solicitud para enviar o recibir datos ya que el socket no está conectado y no se ha proporcionado ninguna dirección, al realizar el envío en un socket de datagramas por medio de una llamada sendto.
vsocket.cpp : closing socket
vsocket.cpp : VSocket() m_pDSMPlugin = NULL
vsocket.cpp : closing socket
vnchttpconnect.cpp : quitting HTTP server thread
vsocket.cpp : closing socket
vncserver.cpp : KillAuthClients() done
vncserver.cpp : KillUnauthClients() done
vncserver.cpp : ~server m_pDSMPlugin = NULL
--Esta clase no existe.
Wed Nov 14 13:37:32 2018
vncserver.cpp : authhosts set to ""
vncproperties.cpp : ***** DBG - Load User Preferences
vncproperties.cpp : clearing user settings
c:\users\rudi\desktop\ultravnc\winvnc\winvnc\vncpasswd.h : PASSWD : FromClear called
vsocket.cpp : VSocket() m_pDSMPlugin = NULL
vncserver.cpp : trying port number 5900
vsocket.cpp : VSocket() m_pDSMPlugin = NULL
Wed Nov 14 13:37:33 2018
vsocket.cpp : closing socket
vsocket.cpp : VSocket() m_pDSMPlugin = NULL
vncsockconnect.cpp : started socket connection thread
vncproperties.cpp : $$$$$$$$$$ ApplyUserPrefs - Plugin Enabled - Call SetDSMPlugin()
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Entry
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Enabled
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Plugin NOT loaded - Try to load it
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Plugin successfully loaded
vnchttpconnect.cpp : started HTTP server thread
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Init plugin call
--El sistema no puede encontrar el archivo especificado.
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - SetPluginParams call
vncserver.cpp : DSMPlugin Params OK
c:\users\rudi\desktop\ultravnc\winvnc\winvnc\vncpasswd.h : PASSWD : ToText called
vncmenu.cpp : IsIconSet
winvnc.cpp : PostAddNewClient IIIII
vncserver.cpp : AutoConnectRetry(): started
vncserver.cpp : Attempting AutoReconnect....
--El identificador de la ventana no es válido.
vsocket.cpp : VSocket() m_pDSMPlugin = NULL
vncserver.cpp : AddClient() started
vncclient.cpp : vncClient() executing...
vncserver.cpp : AddClient() done
vncclient.cpp : client connected : m.y.i.p (1)
vncclient.cpp : DSMPlugin Pointer to socket OK
vncclient.cpp : Send protocolMsg
vncclient.cpp : Send_OK
Wed Nov 14 13:38:35 2018
vncclient.cpp : Keepalive received
vncclient.cpp : Send protocolMsg
vncclient.cpp : Send_OK
Wed Nov 14 13:39:35 2018
vncclient.cpp : Keepalive received
vncclient.cpp : Send protocolMsg
vncclient.cpp : Send_OK


There is no log from 05:41 to 13:37 that I stop and start up the server...

Just add that at 13:37, before reactivating the service, it appears in execution.
Guindillas
 
Posts: 5
Joined: 2018-10-24 17:51

Re: Problem with repeater

Postby Rudi De Vos » 2018-11-14 15:09

option "loglevel" should be higher.
Normal you should see the reconnect running in the background
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5766
Joined: 2004-04-23 10:21

Re: Problem with repeater

Postby Rudi De Vos » 2018-11-14 18:55

Tested
Repeater on uvnc2me off ( sorry)
enabled winvnc with -autoreconnect -id:xxx -connect uvnc2me.com -run
let it run for 10 minutes, activate repeater

1) Test one: repeater off while running wait 10 minutes back on -> OK
2) Test two: repeater of before starting winvnc.exe wait 10 minutes enabled repeater ->OK
same test but with dsm encryption
Both still connect

Anything else i can try to repeat it
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5766
Joined: 2004-04-23 10:21

Re: Problem with repeater

Postby Guindillas » 2018-11-15 19:52

First of all, thank you for your attention.

It seems as if the service is blocked. I activated the log with DebugLevel = 12. I started the server at 19:18 and the repeater at 20:25. The service is active and running. Here copy the log:
Code: Select all
Thu Nov 15 19:18:43 2018
vncserver.cpp : authhosts set to ""
vncproperties.cpp : ***** DBG - Load User Preferences
vncproperties.cpp : clearing user settings
c:\users\rudi\desktop\ultravnc\winvnc\winvnc\vncpasswd.h : PASSWD : FromClear called
vsocket.cpp : VSocket() m_pDSMPlugin = NULL
vncserver.cpp : trying port number 5900
vsocket.cpp : VSocket() m_pDSMPlugin = NULL
Thu Nov 15 19:18:45 2018
vsocket.cpp : closing socket
vsocket.cpp : VSocket() m_pDSMPlugin = NULL
vncproperties.cpp : $$$$$$$$$$ ApplyUserPrefs - Plugin Enabled - Call SetDSMPlugin()
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Entry
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Enabled
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Plugin NOT loaded - Try to load it
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Plugin successfully loaded
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Init plugin call
--El sistema no puede encontrar la ruta especificada.
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - SetPluginParams call
vncserver.cpp : DSMPlugin Params OK
c:\users\rudi\desktop\ultravnc\winvnc\winvnc\vncpasswd.h : PASSWD : ToText called
winvnc.cpp : PostAddNewClient IIIII
vncsockconnect.cpp : started socket connection thread
vnchttpconnect.cpp : started HTTP server thread
vncserver.cpp : AutoConnectRetry(): started
vncserver.cpp : Attempting AutoReconnect....
--El identificador de la ventana no es válido.
vsocket.cpp : VSocket() m_pDSMPlugin = NULL
Thu Nov 15 19:19:06 2018
vsocket.cpp : closing socket
--Se produjo un error durante el intento de conexión ya que la parte conectada no respondió adecuadamente tras un periodo de tiempo, o bien se produjo un error en la conexión establecida ya que el host conectado no ha podido responder.
Thu Nov 15 19:19:07 2018
vncmenu.cpp : user name has changed
--El sistema no puede encontrar el archivo especificado.
vncmenu.cpp : ############## Kill vncMenu thread
vncmenu.cpp : vncmenu killed
winvnc.cpp : ################## Closing Imp Thread
winvnc.cpp : OpenInputdesktop OK
winvnc.cpp : SelectHDESK to Default (3d4) from c0
winvnc.cpp : Username SYSTEM
vncmenu.cpp : vncmenu(server)
vncserver.cpp : authhosts set to ""
vncproperties.cpp : ***** DBG - Load User Preferences
vncproperties.cpp : clearing user settings
c:\users\rudi\desktop\ultravnc\winvnc\winvnc\vncpasswd.h : PASSWD : FromClear called
vncproperties.cpp : $$$$$$$$$$ ApplyUserPrefs - Plugin Enabled - Call SetDSMPlugin()
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Entry
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Enabled
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Is Loaded
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Plugin successfully loaded
Thu Nov 15 19:19:30 2018
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Init plugin call
--El nombre de archivo, el nombre de directorio o la sintaxis de la etiqueta del volumen no son correctos.vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - SetPluginParams call
vncserver.cpp : DSMPlugin Params OK
c:\users\rudi\desktop\ultravnc\winvnc\winvnc\vncpasswd.h : PASSWD : ToText called
vncmenu.cpp : IsIconSet


It seems that the log ends at 19:19, but the service is active at 20:25. I can stop it (then it is active) and start it again and then everything works again. But from 19:30 until 20:25 there is no data in the log.

At 20:44 I stop and start the service and this is the log. The signal already reaches the repeater.
Code: Select all
...
Thu Nov 15 19:19:30 2018
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Init plugin call
--El nombre de archivo, el nombre de directorio o la sintaxis de la etiqueta del volumen no son correctos.vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - SetPluginParams call
vncserver.cpp : DSMPlugin Params OK
c:\users\rudi\desktop\ultravnc\winvnc\winvnc\vncpasswd.h : PASSWD : ToText called
vncmenu.cpp : IsIconSet 
Thu Nov 15 20:44:42 2018
winvnc.cpp : ****************** WaitForSingleObject - Shutdown server
vncmenu.cpp : vncMenu::Shutdown: Close menu - Disconnect all - Shutdown server
--El sistema no puede encontrar el archivo especificado.
vncmenu.cpp : vncMenu WM_CLOSE call - All cleanup done
Thu Nov 15 20:44:44 2018
vncmenu.cpp : quitting from WM_DESTROY
vncserver.cpp : KillAuthClients() done
--El identificador de la ventana no es válido.
vncmenu.cpp : vncmenu killed
winvnc.cpp : ################## Closing Imp Thread
winvnc.cpp : ################## SHUTING DOWN SERVER ####################
--Se intentó liberar una exclusión mutua que no pertenece al proceso.
vncserver.cpp : shutting down server object1
vsocket.cpp : shutdown socket
vsocket.cpp : closing socket
--No se permitió una solicitud para enviar o recibir datos ya que el socket no está conectado y no se ha proporcionado ninguna dirección, al realizar el envío en un socket de datagramas por medio de una llamada sendto.
vsocket.cpp : VSocket() m_pDSMPlugin = NULL
vncsockconnect.cpp : quitting socket connection thread
--Una operación de bloqueo fue interrumpida por una llamada a WSACancelBlockingCall.
Thu Nov 15 20:44:45 2018
vsocket.cpp : closing socket
--No se puede establecer una conexión ya que el equipo de destino denegó expresamente dicha conexión.
vsocket.cpp : shutdown socket
vsocket.cpp : VSocket() m_pDSMPlugin = NULL
--No se permitió una solicitud para enviar o recibir datos ya que el socket no está conectado y no se ha proporcionado ninguna dirección, al realizar el envío en un socket de datagramas por medio de una llamada sendto.
vsocket.cpp : closing socket
vsocket.cpp : VSocket() m_pDSMPlugin = NULL
vsocket.cpp : closing socket
vnchttpconnect.cpp : quitting HTTP server thread
vsocket.cpp : closing socket
vncserver.cpp : KillAuthClients() done
vncserver.cpp : KillUnauthClients() done
vncserver.cpp : ~server m_pDSMPlugin = NULL
--Esta clase no existe.
Thu Nov 15 20:44:54 2018
vncserver.cpp : authhosts set to ""
vncproperties.cpp : ***** DBG - Load User Preferences
vncproperties.cpp : clearing user settings
c:\users\rudi\desktop\ultravnc\winvnc\winvnc\vncpasswd.h : PASSWD : FromClear called
vsocket.cpp : VSocket() m_pDSMPlugin = NULL
vncserver.cpp : trying port number 5900
vsocket.cpp : VSocket() m_pDSMPlugin = NULL
Thu Nov 15 20:44:55 2018
vsocket.cpp : closing socket
vsocket.cpp : VSocket() m_pDSMPlugin = NULL
vncsockconnect.cpp : started socket connection thread
vncproperties.cpp : $$$$$$$$$$ ApplyUserPrefs - Plugin Enabled - Call SetDSMPlugin()
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Entry
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Enabled
vnchttpconnect.cpp : started HTTP server thread
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Plugin NOT loaded - Try to load it
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Plugin successfully loaded
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - Init plugin call
--El sistema no puede encontrar la ruta especificada.
vncserver.cpp : $$$$$$$$$$ SetDSMPlugin - SetPluginParams call
vncserver.cpp : DSMPlugin Params OK
c:\users\rudi\desktop\ultravnc\winvnc\winvnc\vncpasswd.h : PASSWD : ToText called
vncmenu.cpp : IsIconSet
winvnc.cpp : PostAddNewClient IIIII
vncserver.cpp : AutoConnectRetry(): started
Thu Nov 15 20:44:56 2018
vncserver.cpp : Attempting AutoReconnect....
--El identificador de la ventana no es válido.
vsocket.cpp : VSocket() m_pDSMPlugin = NULL
vncserver.cpp : AddClient() started
vncclient.cpp : vncClient() executing...
vncserver.cpp : AddClient() done
vncclient.cpp : client connected : m.y.i.p (1)
vncclient.cpp : DSMPlugin Pointer to socket OK
vncclient.cpp : Send protocolMsg
vncclient.cpp : Send_OK
Thu Nov 15 20:45:57 2018
vncclient.cpp : Keepalive received
vncclient.cpp : Send protocolMsg
vncclient.cpp : Send_OK
Thu Nov 15 20:46:57 2018
vncclient.cpp : Keepalive received
vncclient.cpp : Send protocolMsg
vncclient.cpp : Send_OK


Just indicate that I use the line: service_commandline=-autoreconnect ID:0001 -connect m.y.i.p:5500 in the admin section of ultravnc.ini file to connect to repeater.
Guindillas
 
Posts: 5
Joined: 2018-10-24 17:51

Re: Problem with repeater

Postby Rudi De Vos » 2018-11-16 15:32

I will test again as service, without a logged user.

Possible the cause is the reconnect timer. Could be that without desktop he isn't running proper.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5766
Joined: 2004-04-23 10:21


Return to 1.2.2.x

Who is online

Users browsing this forum: No registered users and 1 guest