Viewer uses port 5900 for repeater if port 80 is specified

Viewer uses port 5900 for repeater if port 80 is specified

Postby vchrizz » 2018-08-25 21:13

because the company, where i work, allows only port 80/443 to the outside world, i need to use those ports to connect to my server.
i'm using 443 already for my openvpn on server, so i would like to use port 80 for vnc repeater.
from home, my whole vnc setup with repeater works fine on default port.
from work, default port is not accessible, so i added a redirect 80 to default vnc port on firewall.
so far so good, but now i think i noticed a bug in uvncviewer (at least on windows).
using 1.2.1.7:
when i enable proxy/repeater and type in: "vncproxy.myserver.com:80" the viewer connects on port 5900
then i thought, maybe this bug is fixed in later version, so i upgraded today to 1.2.2.2 and the behavior is still same.
vchrizz
 
Posts: 1
Joined: 2018-08-25 20:52

Re: Viewer uses port 5900 for repeater if port 80 is specifi

Postby Rudi De Vos » 2018-08-26 15:42

Try ::80
Some old unix legacy ports < 1000 are considered terminals.
We added "::" to indicate it's a port number
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5739
Joined: 2004-04-23 10:21


Return to 1.2.2.x

Who is online

Users browsing this forum: No registered users and 2 guests

cron