1.2.2.3 released

1.2.2.3 released

Postby Rudi De Vos » 2018-09-23 19:05

* Ultr@VNC - Latest modifications – History
1.2.2.3
-update jpeglib to 2.0.0
-update zlib 1.2.11
-Query accept box prevented to switch UAC desktop
-Header changes for gcc
-save query accept settings

ultravnc.ini password encryption.
OPTION: [v]Non portable password.
Normal Vnc use des to encrypt/decrypt the password in the ini file, this is easy to decrypt.
Someone who sees the ulttravnc.ini can copy the passwd string, go home and decrypt it.
When "Non portable password" is checked, the password use some system identifiers like disk/cpu as part of the encryption key.
The password can then only be decrypted on this pc, drawback is that you can't copy the ini to another system.
DOWNLOADS
https://www.uvnc.eu/download/1223/Ultra ... _Setup.exe
https://www.uvnc.eu/download/1223/Ultra ... _Setup.exe
https://www.uvnc.eu/download/1223/UltraVnc_1223.zip
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5790
Joined: 2004-04-23 10:21

Re: 1.2.2.3

Postby Craig87 » 2018-09-24 17:40

Any chance of an IPv6 version? Thanks.
Craig87
 
Posts: 7
Joined: 2018-08-27 18:34

Re: 1.2.2.3

Postby Rudi De Vos » 2018-09-24 19:32

download
only winvnc.exe/vncviewer.exe
XP
IPv6 win8>=
To test use 1222 and overwrite exe

https://www.uvnc.eu/download/1223/UltraVnc_1223.zip
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5790
Joined: 2004-04-23 10:21

Re: 1.2.2.3

Postby Craig87 » 2018-09-26 12:27

I was only able to test IPv6 for vncviewer.exe but it works fine.

Non IPv6 related, but when viewing a computer, I noticed the cursor was selecting in the wrong location.

Image

One the right is my cursor, but the top left of the selection box is where it is registering on the remote computer. The version of winvnc.exe on the remote computer is 1.2.1.2.

Edit: Seems to have been just that one client with the issue.
Craig87
 
Posts: 7
Joined: 2018-08-27 18:34

Re: 1.2.2.3

Postby Rudi De Vos » 2018-09-26 14:45

The cause is the dpi scaling...someone mentioned in another post for 1.2.2.2
I don't know if it's the scaling on the server or on the viewer site...and was unable to repeat it.

*Following that message it happen when dpi is changed, but after you reboot i's back ok

If someone find a method to repeat it...
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5790
Joined: 2004-04-23 10:21

Re: 1.2.2.3

Postby Craig87 » 2018-09-27 11:55

Tested same client again today.

DPI scaling is set to 100% on both viewer PC and remote PC.

Same issue.
Craig87
 
Posts: 7
Joined: 2018-08-27 18:34

Re: 1.2.2.3 pre-release - litte wish

Postby Chaka » 2018-10-13 12:37

Thank you Rudi for your hard work and your new version.

Little wish for the file transfer window:
Could you make folder paths editable, please?
Image
Chaka
8
8
 
Posts: 21
Joined: 2014-04-11 18:01

Re: 1.2.2.3 pre-release

Postby Skyfighter » 2018-10-26 21:43

Found two minor issues with DualMonitor and Tooltip-Text

I've updated a DualMonitor Win7x64 PC with this pre-release (previously v1.2.1.7): after connecting with a viewer and unlocking the remote machine (windows lockscreen) only the content of the first Monitor is shown; the viewer window scroll-bar shows the width of both remote monitors but the second monitor (on the right side of the viewer) is simply black without any content (no windows, no desktop icons - nothing). Using the "Switch Monitor"-Button of the viewer results in:
1. press: only second monitor is shown (OK)
2. press: both monitors are shown (OK, now the viewer sees the content of both monitors)
3. press: only first monitor is shown (OK)
4. press: both monitors are shown (OK, the viewer sees the content of both monitors)
=> Looks like there is a bug if both monitors should be shown on viewer connect (perhaps because auf the MirrorDriver or the Windows LockScreen on Viewer-Connect? Didn't experiment any further...)
Note1: If both monitors are corrctly shown on the viewer side and the lockscreen on the server side kicks-in: after unlock the machine (via viewer) the viewer still shows both monitors correctly. (Maybe it has nothing to do with the lock-screen on the initial connect after all?)
Note2: This issue didn't exist with the previous installed version v1.2.1.7 (= both screens were shown correctly on viewer connect/after unlock of the remote machine)

The Tooltip of the WinVNC Systray Icon shows: "WinVNC - [IP] - [PCNAME] - service - ddengine"
Shouldn't it show mirrordriver instead of ddengine? (According to the performance the MirrorDrivers seems to be used. ...and the ddengine only works on >=win8!?) The "UltraVNC Server Property Page" (systray icon -> context menu -> properties) has the old well-known "Check the Mirror Driver"-Button (next to the activated checkbox "Mirror Driver") which brings up the following message:
Code: Select all
---------------------------
1.00.22
---------------------------
Driver found.
Driver version OK
driver Active access okA mirrior driver can only be started if winvnc is a service or running as admin

---------------------------
OK   
---------------------------

I'm not sure: is this the correct message if the mirrordriver is currently in use?
((
The UltraVNC Settings application doesn't have a (never had?) a "Check Mirror Driver"-Button on the "ScreenCapture"-Tab and the "Mirror Driver"-Checkbox is labeled "Desktop Duplication (restart on change required)". That's no real problem because mirrordriver and ddengine use the same ini-setting (EnableDriver=1) so that is OK as long as you know what you do (perhaps it is a little confusing for a normal user).
))

stripped UltraVNC.ini @ Server
Code: Select all
[ultravnc]
passwd=XXXXXXXXXXXXXXXXXX
passwd2=XXXXXXXXXXXXXXXXXX
[admin]
DebugMode=0
UseDSMPlugin=1
DSMPlugin=SecureVNCPlugin64.dsm
HTTPConnect=0
RemoveWallpaper=1
RemoveAero=1
QuerySetting=4
QueryTimeout=20
QueryAccept=2
QueryIfNoLogon=0
primary=1
secondary=1
InputsEnabled=1
LockSetting=1
[poll]
TurboMode=1
PollUnderCursor=0
PollForeground=0
PollFullScreen=1
OnlyPollConsole=0
OnlyPollOnEvent=0
EnableDriver=1
EnableHook=1
EnableVirtual=0
SingleWindow=0
SingleWindowName=
MaxCpu=40
EnableWin8Helper=0


And last but not least: Thanks for your hard work, Rudi!
Skyfighter
40
40
 
Posts: 96
Joined: 2014-12-31 22:10

Re: 1.2.2.3 pre-release

Postby Skyfighter » 2018-10-27 07:48

Another one: can't transfer files from remote machine to local machine if the files are stored on mapped network drive@remote machine*. I blieve that worked in the previous version?
* File Transfer Window did not seem to do anything a long time, using both cancel Buttons I crashed the server and couldn't reconnect for long time. On a second test the File Transfer Window showed "ERROR: < X:\Path\folder\[FolderToTransfer] > is not accessible on Remote Machine" in the status bar. Manually zipped the folder & copied it to a local drive on the remote machine, from there transfer via uvnc worked flawless (size was only few kb).
Skyfighter
40
40
 
Posts: 96
Joined: 2014-12-31 22:10

Re: 1.2.2.3 pre-release

Postby Chrispy » 2018-10-27 11:06

Skyfighter wrote:Found two minor issues with DualMonitor and Tooltip-Text

I've updated a DualMonitor Win7x64 PC with this pre-release (previously v1.2.1.7): after connecting with a viewer and unlocking the remote machine (windows lockscreen) only the content of the first Monitor is shown; the viewer window scroll-bar shows the width of both remote monitors but the second monitor (on the right side of the viewer) is simply black without any content (no windows, no desktop icons - nothing). Using the "Switch Monitor"-Button of the viewer results in:
1. press: only second monitor is shown (OK)
2. press: both monitors are shown (OK, now the viewer sees the content of both monitors)
3. press: only first monitor is shown (OK)
4. press: both monitors are shown (OK, the viewer sees the content of both monitors)
=> Looks like there is a bug if both monitors should be shown on viewer connect (perhaps because auf the MirrorDriver or the Windows LockScreen on Viewer-Connect? Didn't experiment any further...)
Note1: If both monitors are corrctly shown on the viewer side and the lockscreen on the server side kicks-in: after unlock the machine (via viewer) the viewer still shows both monitors correctly. (Maybe it has nothing to do with the lock-screen on the initial connect after all?)
Note2: This issue didn't exist with the previous installed version v1.2.1.7 (= both screens were shown correctly on viewer connect/after unlock of the remote machine)

...


Sorry, does not sound to me like your system was really updated because these were the errors that were fixed in 1.2.2.2. Could you please try 1.2.2.2?
Last edited by Chrispy on 2018-10-27 11:57, edited 1 time in total.
User avatar
Chrispy
40
40
 
Posts: 89
Joined: 2018-07-11 09:06

Re: 1.2.2.3 pre-release

Postby Rudi De Vos » 2018-10-27 11:40

I will review uvnc_settings.exe and tooltip

Ddengine en mirror driver has a lot of common code if the tooltip "ddengine" is set a common part it could overwrite the
previous set "mirror driver"

driver Active access ok == "Mirror driver is current is use"
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5790
Joined: 2004-04-23 10:21

Re: 1.2.2.3 pre-release

Postby Skyfighter » 2018-10-29 20:04

@Chrispy
Systray-icon > context menu > About WinVNC: UltraVNC Server v1.2.2.3 Build Sep 29 2018 20:03:26
What do you mean with "really updated"? ...anything else I should check?
Skyfighter
40
40
 
Posts: 96
Joined: 2014-12-31 22:10

Re: 1.2.2.3 pre-release

Postby Chrispy » 2018-10-31 11:21

Screensize wrong after logon screen has been corrected as of 1173.

Rudy: Could you please rebuild, Thanks?
User avatar
Chrispy
40
40
 
Posts: 89
Joined: 2018-07-11 09:06


Re: 1.2.2.3 pre-release

Postby Skyfighter » 2018-11-01 06:56

Chrispy wrote:Screensize wrong after logon screen has been corrected as of 1173.

Thanks for the update, but that did not change anything - it behaves exactly the same as before. :(
Skyfighter
40
40
 
Posts: 96
Joined: 2014-12-31 22:10

Re: 1.2.2.3 pre-release

Postby Chrispy » 2018-11-01 07:02

Skyfighter wrote:I've updated a DualMonitor Win7x64 PC with this pre-release (previously v1.2.1.7): after connecting with a viewer and unlocking the remote machine (windows lockscreen) only the content of the first Monitor is shown; the viewer window scroll-bar shows the width of both remote monitors but the second monitor (on the right side of the viewer) is simply black without any content (no windows, no desktop icons - nothing). Using the "Switch Monitor"-Button of the viewer results in:


You still have this issue?

I tested and got only 1 monitor, before I also had the scrollbar.

I see this also happens when you have in your ini:
Code: Select all
primary=1
secondary=1
User avatar
Chrispy
40
40
 
Posts: 89
Joined: 2018-07-11 09:06

Re: 1.2.2.3 pre-release

Postby Chrispy » 2018-11-01 07:36

OK, got it now in 1174 - secondary from ini not handled correctly after login screen
User avatar
Chrispy
40
40
 
Posts: 89
Joined: 2018-07-11 09:06

Re: 1.2.2.3 pre-release

Postby Skyfighter » 2018-11-02 09:41

Thank you very much for looking into it, Chrispy! Ready to test it as soon as there are new test-bins (x64, please)...

Working with the 1173...there is another annoying issue (same win7 x64 machine as above): After unlocking remote machine (windows lockscreen) & using "SwitchMonitor"-Button...viewer shows both remote displays (left: first, right: second). Working on the first display = all good. While working on the second display (right half of the viewer-window) the remote cursor is visible as long as I move my mouse, if I stop moving my mouse most of the time the cursor vanishes from the second display (right viewer half) and appears on the first display (left viewer half) [in approx. the same x/y-coordinate where the cursor should be on the second display].
hmm...while writing this the screen saver/lockscreen of the remote machine kicked in. After re-unlock of the remote machine (I still see both displays on the viewer side) the cursor behaves absolutely perfect on both displays. Closing the viewer and reconnect...same behaviour as described above. Maybe the cursor problem is a result of the missing second display during the connection setup? Will check if the new bins solve that, too.
Skyfighter
40
40
 
Posts: 96
Joined: 2014-12-31 22:10

Re: 1.2.2.3 pre-release

Postby Chrispy » 2018-11-02 10:20

Hi skyfighter, Rudi is not available till Sunday. I could compile win7/10 x64, without signing, and make it available for download (exe only) for testing from my site. Is that ok?
User avatar
Chrispy
40
40
 
Posts: 89
Joined: 2018-07-11 09:06

Re: 1.2.2.3 pre-release

Postby Skyfighter » 2018-11-02 11:44

Yes, of course - would be great!
Skyfighter
40
40
 
Posts: 96
Joined: 2014-12-31 22:10

Re: 1.2.2.3 pre-release

Postby Chrispy » 2018-11-02 11:53

You can find the zipped exe (win7/10 x64) at http://www.resource-solutions.de/ultra/winvnc.zi_p for revision 1174.
User avatar
Chrispy
40
40
 
Posts: 89
Joined: 2018-07-11 09:06

Re: 1.2.2.3 pre-release

Postby Skyfighter » 2018-11-02 12:45

perfect, your r1174 fixed:
- missing/black second monitor on connect (altough primary=1 + secondary=1 has been set)
- jumping cursor (second monitor -> first monitor)
Thank you very much, Chrispy! :thumbs:

(was a little bit irritated because the about-window says "Build: aug 4 2018 15:47:47" but I've definately tested your unsigned exe, double-checked that with it's checksum)

For now I've only two very minor issues left:
- Tooltip of winvnc.exe: shows ddengine instead of MirrorDriver @ Win7 (although MirrorDriver works + is in use)
- File/Folder-Transfer from Mapped Network Drive (UNC-Path) @ RemoteMachine to Viewer-Machine -> nothing happens for a long time (?until timeout?), then Error in FileTransfer-Window (File/Folder is not accessible on Remote Machine)
Skyfighter
40
40
 
Posts: 96
Joined: 2014-12-31 22:10

Re: 1.2.2.3 pre-release

Postby Chrispy » 2018-11-02 13:27

Skyfighter wrote:perfect, your r1174 fixed:
- missing/black second monitor on connect (altough primary=1 + secondary=1 has been set)
- jumping cursor (second monitor -> first monitor)
Thank you very much, Chrispy! :thumbs:

(was a little bit irritated because the about-window says "Build: aug 4 2018 15:47:47" but I've definately tested your unsigned exe, double-checked that with it's checksum)


Fantastic, thanks for testing!


Skyfighter wrote:For now I've only two very minor issues left:
- Tooltip of winvnc.exe: shows ddengine instead of MirrorDriver @ Win7 (although MirrorDriver works + is in use)
- File/Folder-Transfer from Mapped Network Drive (UNC-Path) @ RemoteMachine to Viewer-Machine -> nothing happens for a long time (?until timeout?), then Error in FileTransfer-Window (File/Folder is not accessible on Remote Machine)


Ok, I will look into these, but first some questions:
1. What tool tip are you talking about?
2. Could you give a full path example for the file transfer?

Maybe, you could turn on logging for FT problem?

Thanks
User avatar
Chrispy
40
40
 
Posts: 89
Joined: 2018-07-11 09:06

Re: 1.2.2.3 pre-release

Postby Skyfighter » 2018-11-02 14:17

Chrispy wrote:1. What tool tip are you talking about?

On my machine UltraVNC runs as a service and if the service is started there is a systray icon next to the windows date/clock (context menu of the icon has Properties/Admin Properties/About WinVNC/....): if you hover this systray icon whith your cursor you get a tooltip which shows some details, e.g. "WinVNC - [IP] - [PCNAME] - service - [captureengine]". (the [captureengine] after the last hyphen is obviously wrong under Win7: there I see ddengine instead of MirrorDriver)

Chrispy wrote:2. Could you give a full path example for the file transfer?

In the LAN of the remote machine is a server which has a smb-share; at the remote machine this share is mapped as a network drive -> the remote machine has a drive "X" which maps to \\server\share (see https://support.microsoft.com/en-gb/help/4026635/windows-map-a-network-drive). Now I use ultravnc to connect to the remote machine, open FileTransfer and select drive "[ X: ]", then I choose one of the listed folders (full path example: \\server\share\TEMP\FolderToTransfer = X:\TEMP\FolderToTransfer) and click on "<< Receive" **...nothing happens and after ~30-60 seconds the FileTransfer Window shows something like "File/Folder is not accessible on Remote Machine"
[s]** I just realize both Buttons (Send & Receive) are greyed-out using your r1174 (network drive or local disc doesn't matter); perhaps because of unsigned exe? (the winvnc.exe somehow has to impersonate the user which is currently logged-in @ remote machine, I could imagine there are unmet security-requirements)[/s] <-- That was bullshit. (You have to choose a folder on local & remote machine - otherwise send / receive buttons are greyed out - makes perfectly sense.)
Last edited by Skyfighter on 2018-11-03 18:43, edited 1 time in total.
Skyfighter
40
40
 
Posts: 96
Joined: 2014-12-31 22:10

Re: 1.2.2.3 pre-release

Postby Chrispy » 2018-11-02 15:19

Skyfighter wrote:On my machine UltraVNC runs as a service and if the service is started there is a systray icon next to the windows date/clock (context menu of the icon has Properties/Admin Properties/About WinVNC/....): if you hover this systray icon whith your cursor you get a tooltip which shows some details, e.g. "WinVNC - [IP] - [PCNAME] - service - [captureengine]". (the [captureengine] after the last hyphen is obviously wrong under Win7: there I see ddengine instead of MirrorDriver)




Ok, I just tried on win 7 and as soon as I connect and the mirror driver is connected then I see the tooltip text change to "driver" at the end.
User avatar
Chrispy
40
40
 
Posts: 89
Joined: 2018-07-11 09:06

Re: 1.2.2.3 pre-release

Postby Skyfighter » 2018-11-02 15:58

hm, try:
1. lock remote machine (shortcut: WIN-key + L)
2. connect using uvnc, unlock remote machine, look at the tooltip
...I always see "... service - ddengine"
Skyfighter
40
40
 
Posts: 96
Joined: 2014-12-31 22:10

Re: 1.2.2.3 pre-release

Postby Chrispy » 2018-11-02 17:48

Ok, thanks, I can reproduce this now. I will look into it and get back to you.
User avatar
Chrispy
40
40
 
Posts: 89
Joined: 2018-07-11 09:06

Re: 1.2.2.3 pre-release

Postby Chrispy » 2018-11-03 13:22

Fixed File Transfer of mapped network drives in r1175.

You can find the zipped exe (win7/10 x64) at http://www.resource-solutions.de/ultra/winvnc.zi_p for revision 1175.

Skyfighter, please test.
User avatar
Chrispy
40
40
 
Posts: 89
Joined: 2018-07-11 09:06

Re: 1.2.2.3 pre-release

Postby Skyfighter » 2018-11-03 18:39

r1175: transfer files to & from network drives @ Remote Machine works! Sending a folder to network drive at remote machine works, too. But receiving a folder from a network drive at remote machine does not work: nothing happens for approx. 80 seconds, then statusbar says "ERROR: File < X:\TEMP\FolderToTransfer > is not accessible on Remote Machine".
=> You are on the right track! :)
Skyfighter
40
40
 
Posts: 96
Joined: 2014-12-31 22:10

Re: 1.2.2.3 pre-release

Postby Chrispy » 2018-11-03 19:15

I did not change the viewer, it needs to be fixed too. Will get you a new viewer tomorrow.
User avatar
Chrispy
40
40
 
Posts: 89
Joined: 2018-07-11 09:06

Next

Return to 1.2.2.x

Who is online

Users browsing this forum: No registered users and 2 guests

cron