1.2.2.4 pre-release

Re: 1.2.2.3 pre-release

Postby Chrispy » 2018-11-16 12:54

Mouse position fixed in r1189
User avatar
Chrispy
40
40
 
Posts: 93
Joined: 2018-07-11 09:06

Re: 1.2.2.3 pre-release

Postby Lucent » 2018-11-17 02:00

Can you give us the download link for testing? Thanks
Lucent
8
8
 
Posts: 27
Joined: 2018-08-27 12:33

Re: 1.2.2.3 pre-release

Postby Chrispy » 2018-11-17 07:23

You can find the zipped exe (win7/10 x64) at http://www.resource-solutions.de/ultra/winvnc.zi_p for revision 1189.
User avatar
Chrispy
40
40
 
Posts: 93
Joined: 2018-07-11 09:06


Re: 1.2.2.3 pre-release

Postby Skyfighter » 2018-11-19 11:40

Chrispy wrote:Mouse position fixed in r1189

r1189: Tested ( https://forum.ultravnc.net/viewtopic.php?f=72&t=34183&start=30#p104900 ) and it is fixed - thanks Chrispy! :thumbs:

r1189 further observations:
1) uvnc_settings.exe -> screen capture tab: @Win7 MirrorDriver option and button shown (OK) but button doesn't have any functionality (uvnc_settings.exe running as admin using admin account in UAC-PopUp) [To me the MirrorDriver-Button does not really matter, just wanted to let you know] // @Win10 DDengine option shown (OK)
2) winvnc.exe Tooltip @Win7 using MirrorDriver: Tooltip ends with " ... - service - " = does not list the used capture plugin(s) although MirrorDriver is definitely in use // @Win10 using DDengine: Tooltip lists "ddengine" (OK)
...otherwise so far completely error-free / nothing to complain. :D
Skyfighter
40
40
 
Posts: 105
Joined: 2014-12-31 22:10

Re: 1.2.2.4 pre-release

Postby Chrispy » 2018-11-19 12:47

r1191 - Mirror driver button correct with Win 7 and uvnc_settings
User avatar
Chrispy
40
40
 
Posts: 93
Joined: 2018-07-11 09:06

Re: 1.2.2.4 pre-release

Postby Sander02 » 2018-11-21 10:55

Anyone have seen a remote screen filled with horizontal lines and cursor position that is not in sync? I get this on some machines(uvnc 1.2.2.3 and before) and when the user logs off, the screen is fine again. Might be related to custom scale. I set it in registry for all users to 100% but windows says it's 175 procent. But if you click on custom scale it's really 100% So that is working fine. I'm not having all details in place at the moment but I think it can be solved by clicking on disable custom scale.
Sander02
8
8
 
Posts: 20
Joined: 2018-06-16 10:53

Re: 1.2.2.4 pre-release

Postby Sander02 » 2018-11-21 11:04

Sander02 wrote:Anyone have seen a remote screen filled with horizontal lines and cursor position that is not in sync? I get this on some machines(uvnc 1.2.2.3 and before) and when the user logs off, the screen is fine again. Might be related to custom scale. I set it in registry for all users to 100% but windows says it's 175 procent. But if you click on custom scale it's really 100% So that is working fine. I'm not having all details in place at the moment but I think it can be solved by clicking on disable custom scale.


Sorry, I just read the cursor sync might be already fixed, I will try the last build and let you know.
Sander02
8
8
 
Posts: 20
Joined: 2018-06-16 10:53

Re: 1.2.2.3 pre-release

Postby Lucent » 2018-11-21 21:58

Chrispy wrote:Mouse position fixed in r1189

Perfect, thanks!

I've found two issues:
1.- Server w10 dual monitor and ddengine enabled. if viewer, with w10 too, set to view only one monitor and move a window from the server then you can see artifacts.
The effect is the same that this video https://streamable.com/e6dah but with the latest release I can only reproduce if viewer set to view only one monitor.

2.- Caps lock viewtopic.php?f=72&t=34080
Lucent
8
8
 
Posts: 27
Joined: 2018-08-27 12:33

Re: 1.2.2.4 pre-release

Postby Sander02 » 2018-11-22 12:12

Just replaced 1.2.2.3 winvnc.exe on remote machine to 1.2.2.4 and mouse cursor was fixed.

One question: In our organization are multiple versions installed. Can I just replace all winvnc.exe files and leave all other files like .dll untouched? Or do I need to deploy the complete software package?
Sander02
8
8
 
Posts: 20
Joined: 2018-06-16 10:53

Re: 1.2.2.4 pre-release

Postby Rudi De Vos » 2018-11-22 15:05

You can replace the exe, no dll changes.
Just make sure you don't replace a 32bit with a 64bit or invers
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5926
Joined: 2004-04-23 10:21

Re: 1.2.2.4 pre-release

Postby Lucent » 2018-12-18 09:44

Anyone can reproduce the issue with caps key? viewtopic.php?f=72&t=34080
Lucent
8
8
 
Posts: 27
Joined: 2018-08-27 12:33

Re: 1.2.2.4 pre-release

Postby ddbivens » 2018-12-20 11:52

It might only be cosmetic... The viewer version number in the pre-release shows 1.2.2.3.
The viewer version number in the last 1.2.2.4 before the pre-release showed 1.2.2.4.
I just want to say that UltraVNC is the best.
Thanks for all your hard work and for this excellent program!!!
ddbivens
40
40
 
Posts: 85
Joined: 2015-12-26 14:53
Location: Tellico Plains, TN 37385 USA

Re: 1.2.2.4 pre-release

Postby Skyfighter » 2018-12-28 11:45

v1.2.2.4 r1189 build Nov 17 2018 13:24:01 (server) / 13:25:46 (viewer)
Bug: cursor (on viewer-side) vanishes (viewer-setting: track remote cursor locally)
Description: After viewer-connect cursor is visible. Open viewer settings (CTRL+ALT+F6) and press OK -> cursor vanishes. (You can repeat that as often as you want: the cursor is stays gone - only a small rectangle is visible). You can bring back the cursor if you open the viewer settings, change the encoder (e.g. Tight -> u2) and press OK. But if you re-open the viewer settings and press ok the cursor vanishes again.
(tested with win10 and win7)

EDIT: Saw there is now a pre-release zip with winvnc.exe build on "Dec 17 2018 21:58:23" -> it has the cursor problem, too.
Skyfighter
40
40
 
Posts: 105
Joined: 2014-12-31 22:10

Re: 1.2.2.4 pre-release

Postby Thomas Levering » 2019-01-09 14:02

are there newer Signed Exe?
Latest r1189 and SVN is r1200
Thomas Levering
8
8
 
Posts: 22
Joined: 2015-01-23 06:45


Re: 1.2.2.4 pre-release

Postby Thomas Levering » 2019-01-14 14:34

i found a small bug,
VNC Viewer to dual screen server
[options]
selectedscreen=0

Viewer is Open in Window, Window is bigger than first Screen -> all OK
Change to Full Screen -> all OK
Change back to Window -> the right side of the Window is black -> same as selectedscreen=1 (Window size is OK)
Thomas Levering
8
8
 
Posts: 22
Joined: 2015-01-23 06:45

Re: 1.2.2.4 pre-release

Postby Thomas Levering » 2019-01-14 14:50

I Tested the Repeater Reconnect.

If the keepalive is missing, this is not detected?
The Connection is Over a TLS Tunnel,
when I disconnect the TLS Tunnel this is detected -> 9:17:59
(I have no Problem with this.I close the Tunnel if no Data/Keepalive)

WinVNC.log

Mon Jan 14 08:57:10 2019
winvnc.cpp : PostAddNewClient IIIII
vncserver.cpp : AddClient() started
vncclient.cpp : client connected : 127.0.0.1 (1)
vncclient.cpp : Send protocolMsg
vncclient.cpp : Send_OK
Mon Jan 14 08:58:13 2019
vncclient.cpp : Keepalive received
vncclient.cpp : Send protocolMsg
vncclient.cpp : Send_OK
Mon Jan 14 08:59:14 2019
vncclient.cpp : Keepalive received
vncclient.cpp : Send protocolMsg
vncclient.cpp : Send_OK
Mon Jan 14 09:00:14 2019
vncclient.cpp : Keepalive received
vncclient.cpp : Send protocolMsg
vncclient.cpp : Send_OK

Disconnect TCP

Mon Jan 14 09:17:59 2019
vsocket.cpp : zero bytes read1
vncclient.cpp : !Send_OK || !Recv_OK
vncclient.cpp : PostAddNewClient I




UltraVNC.ini

[admin]
FileTransferEnabled=1
FTUserImpersonation=0
BlankMonitorEnabled=0
BlankInputsOnly=0
DefaultScale=1
UseDSMPlugin=1
DSMPlugin=SecureVNCPlugin64.dsm
primary=1
secondary=1
SocketConnect=0
HTTPConnect=0
AutoPortSelect=0
InputsEnabled=1
LocalInputsDisabled=0
IdleTimeout=0
EnableJapInput=0
QuerySetting=2
QueryTimeout=10
QueryAccept=0
LockSetting=0
RemoveWallpaper=0
RemoveEffects=1
RemoveFontSmoothing=0
RemoveAero=0
DebugMode=2
Avilog=0
DebugLevel=8
AllowLoopback=1
LoopbackOnly=1
AllowShutdown=1
AllowProperties=0
AllowEditClients=0
FileTransferTimeout=600
KeepAliveInterval=5
IdleInputTimeout=0
DisableTrayIcon=0
rdpmode=0
MSLogonRequired=0
NewMSLogon=0
ConnectPriority=1
UseRegistry=0
kickrdp=0
service_commandline=
AuthRequired=1
AuthHosts=
PortNumber=5900
HTTPPortNumber=5800
QueryIfNoLogon=0
clearconsole=0
accept_reject_mesg=
DSMPluginConfig=SecureVNC;0;0x00101001;
EnableWin8Helper=0
QueryDisableTime=0
Secure=0
[poll]
TurboMode=0
PollUnderCursor=0
PollForeground=0
PollFullScreen=1
OnlyPollConsole=0
OnlyPollOnEvent=0
EnableDriver=0
EnableHook=1
EnableVirtual=0
SingleWindow=0
SingleWindowName=
MaxCpu=100
autocapt=1
Thomas Levering
8
8
 
Posts: 22
Joined: 2015-01-23 06:45

Re: 1.2.2.4 pre-release

Postby Skyfighter » 2019-01-22 11:10

v1.2.2.4 r1202 build Jan 12 2019 19:46:22 (server@Win7, DualMonitor, MirrorDriver) / 19:50:42 (viewer@Win10):
After connecting I see the Windows LockScreen of the remote station but after logging in: only black screen (no windows, no Desktop Icons, no TaskBar)! (tested u2 and tight encoding) Further observation: after first login-attempt winvnc.exe @Server stays at 25% CPU usage - no matter if client is connected or not. Following connection-attempts stall on "Password accepted" @viewer-side. Downgraded winvnc.exe @server to r1197, which does NOT have this Bug.
(r1202 Client+Server @Win10 with both machines having only one Monitor: worked as expected in a short test.)

Chrispy wrote:r1191 - Mirror driver button correct with Win 7 and uvnc_settings

tested r1197, FYI: Button has no functionality.
Skyfighter
40
40
 
Posts: 105
Joined: 2014-12-31 22:10

Re: 1.2.2.4 pre-release

Postby Rudi De Vos » 2019-01-22 21:34

Introduced in [r1202] fixed in [r1205]

[r1208] security updates 2019-01-22 19:43:25
[r1207] security updates 2019-01-20 19:39:19
[r1206] security updates 2019-01-20 16:07:05
[r1205] DDengine changes require reset of event else the server get in a endless loop.2019-01-20 15:18:31
[r1204] security updates 2019-01-17 21:23:45
[r1202] ddengine (change display size while running) fix

Download Files updated today (22/01/2019) winvnc.exe and vncviewer.exe

A lot of changes in the viewer src. Added extra memory checks and parameter rules.

Sample: suppose you connect to a server with size 1280x1024 and later he send an update at position 5000,5000.
Then this update is written in unallocated memory... Someone could create a fake server and ask you to connect and possible inject some code this way. I don't know if it's realy possible, but an extra check never hurt.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5926
Joined: 2004-04-23 10:21

Re: 1.2.2.4 pre-release

Postby Chaka » 2019-01-23 08:44

Thanks Rudi for the update.
But I have a problem here running latest winvnc.exe with mirror driver. I can connect for some milliseconds then the viewer window disappears. The content of viewer window is blue only. Without mirror driver using hookDll it works fine. Windows 10 using ddengine is working fine, too. So for the machine using mirror driver I changed back to v1.2.2.3, works fine.
I'm open for suggestions or at least confirmations :wink:
Chaka
8
8
 
Posts: 24
Joined: 2014-04-11 18:01

Re: 1.2.2.4 pre-release

Postby Rudi De Vos » 2019-01-23 10:54

mirror driver found and fixed
downloads updated
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5926
Joined: 2004-04-23 10:21

Re: 1.2.2.4 pre-release

Postby Chaka » 2019-01-24 12:01

I'm sorry same problem with updated version. WinVNC.exe v1.2.2.3 works fine.
Nevermind, installed new v1.2.2.4 a second time, now it works, strange but true.
Last edited by Chaka on 2019-01-24 20:16, edited 1 time in total.
Chaka
8
8
 
Posts: 24
Joined: 2014-04-11 18:01

Re: 1.2.2.4 pre-release

Postby Skyfighter » 2019-01-24 17:50

Skyfighter wrote:v1.2.2.4 r1202 build Jan 12 2019 19:46:22 (server@Win7, DualMonitor, MirrorDriver) / 19:50:42 (viewer@Win10):
After connecting I see the Windows LockScreen of the remote station but after logging in: only black screen (no windows, no Desktop Icons, no TaskBar)! (tested u2 and tight encoding) Further observation: after first login-attempt winvnc.exe @Server stays at 25% CPU usage - no matter if client is connected or not. Following connection-attempts stall on "Password accepted" @viewer-side. Downgraded winvnc.exe @server to r1197, which does NOT have this Bug.
(r1202 Client+Server @Win10 with both machines having only one Monitor: worked as expected in a short test.)

Thanks Rudi! Using files downloaded a few minutes ago my problem is fixed. v1.2.2.4 ??r1209?? build Jan 22 2019 23:52:21 (server@Win7, DualMonitor, MirrorDriver) / 23:53:35 (viewer@Win10)
Skyfighter
40
40
 
Posts: 105
Joined: 2014-12-31 22:10

Re: 1.2.2.4 pre-release

Postby Skyfighter » 2019-01-27 11:14

Skyfighter wrote:v1.2.2.4 r1189 build Nov 17 2018 13:24:01 (server) / 13:25:46 (viewer)
Bug: cursor (on viewer-side) vanishes (viewer-setting: track remote cursor locally)
Description: After viewer-connect cursor is visible. Open viewer settings (CTRL+ALT+F6) and press OK -> cursor vanishes. (You can repeat that as often as you want: the cursor stays gone - only a small rectangle is visible). You can bring back the cursor if you open the viewer settings, change the encoder (e.g. Tight -> u2) and press OK. But if you re-open the viewer settings again and press ok (without changing any setting!) the cursor vanishes again.
(tested with win10 and win7)

Bug still exists using v1.2.2.4 ??r1209?? build Jan 22 2019 23:52:21 (server@Win7, DualMonitor, MirrorDriver) / 23:53:35 (viewer@Win10).

And I have a strange one: I have one PC with a single 4K Monitor running Win10; If I connect to this PC from a Win7 PC (with Full HD Monitor) on the viewer side the cursor is always missing (no matter what I try: can't get the cursor to show up). But:
1) Connecting (from this Win7 PC) to other Win10 PCs which have a Full-HD Monitor the cursor is is shown.
2) Connecting from other Win10 PCs (with Full-HD Monitor) to the the Win10 PC with the 4K Monitor the cursor is shown, too.
No clue that's going on...
Skyfighter
40
40
 
Posts: 105
Joined: 2014-12-31 22:10

Re: 1.2.2.4 pre-release

Postby AnotherUVNCuser » 2019-01-27 15:48

Hello all,

I am planning to update from 1.2.1.6 (yes, this is no joke).

I basically want to be able to download/upload <=> network drives/shares but i'm uncertain if i should update to 1.2.2.3 or the latest compiled pre-release 1.2.2.4
(i don't know if there have been any changes/fixes in the pre-release that are related to network drive/share filetransfers).

With 1.2.1.6 i haven't been able to filetransfer between network dives/shares so i guess in order to make this work updating to a newer version is necessary/inevitable.


Thanks? ;)
AnotherUVNCuser
20
20
 
Posts: 62
Joined: 2017-09-13 00:40

Re: 1.2.2.4 pre-release

Postby CPC » 2019-02-12 21:51

Hello

I see a small issue... When using the latest 1.2.2.4 (2019.01.23) (32 bit) on Windows 10 for both server and viewer... When the viewer ends a reverse connection session... The vnc server computer posts an event log in Windows logs/application... Event 1000, Application Error. The server end also posts an "information" event as follows.

Fault bucket 2076382006624544177, type 1
Event Name: APPCRASH
Response: Not available
Cab Id: 0
Problem signature:
P1: winvnc.exe
P2: 1.2.2.4
P3: 5c48c89b
P4: winvnc.exe
P5: 1.2.2.4
P6: 5c48c89b
P7: c0000005
P8: 00067279
P9:
P10:
There seems to be an error with regards to the -kill / close vnc???

The remote session runs fine... I just noticed the error in the event log upon each disconnect.
If I switch the vncserver to 1.2.2.3. (on the server) I do not get the error in the event log.
If I switch back to 1.2.2.4, the error is posted again immediately upon disconnect of the session.

Thank you in advance. (Also..(IF you get time)...see my feature request for VNCviewer to have optional sound notification upon reverse-connections)
UVNC user for many years... thanks for a great tool :P

CPC
CPC
8
8
 
Posts: 25
Joined: 2010-10-08 15:31


Return to 1.2.2.x

Who is online

Users browsing this forum: No registered users and 2 guests