Stuck on: "Negotiate Protocol Version"

Find help for Frequently Asked Questions here - please look here first before posting an already answered question.

Stuck on: "Negotiate Protocol Version"

Postby bevtech » 2006-02-26 19:29

<b>Problem: The session hangs on "Negotiate Protocol Version"</b>

This is a very common error, occurring when the "handshake" fails between the client and the server.

<b>Solution/Explanation 0 (4/2011, from Rudi):</b>

The viewer the wait for the server rfb protocol..
The server send a message back ( RFB...) but the viewer never get it.
Viewer keeps waiting until timeout and looks locked.

This is usual caused by a firewall or other security software.

If the viewer connect to pc A and not pc B, try to temp disable the firewall of pc B. If it works without, add a rule to allow outgoing tcp port 5900.
Then enable the firewall back.

<b>Older solutions:</b>

<b>Solution 1. </b>
If you are using Norton Antivirus then disable the worm protection..:) or change the default port;)

From User Redge:

<b>Solution 2</b>
symptom:
vncviewer ... connecting to wrong vnc server or misspelling
every time you clicked Cancel ... vncviewer appear as "ghost"

solution:
Right click over systray clock... left click Task Manager...
Process... end all process Image name: vncviewer.exe

restart vncviewer .... connect to correct vnc server... :-)


<b>Solution 3</b>

Make sure that a software firewall isnt causing problems and is configured correctly

symantec client firewall may cause you an issue :idea:

<b>Solution 4</b>
added by redge:
Lavasoft ad-watch could block the SingleClick, thank to french user mgguy from forum.ultravnc.fr who give this solution

<b>Solution 5</b>

If you are using encryption disable it and see if it works.
Triple check that the *.dsm file and if using *.key file are the same version on both the viewer and the server. If the dsm file are not the same version it will cause this problem

<b>Solution 6</b>
if you use encryption plugin (msrc4plugin)
At the Server machine via Admin Properties find the box that says
Enable Javaviewer (http connect)
and uncheck it.
be sure to allow the permissions when clicking Apply and OK
I think recent and older Java updates affect this.
ian
Last edited by bevtech on 2011-04-04 16:42, edited 8 times in total.
bevtech
Super-Mod
Super-Mod
 
Posts: 2191
Joined: 2005-08-03 14:07
Location: Pennsylvania, United States

Return to FAQ

Who is online

Users browsing this forum: No registered users and 2 guests