How to install UltraVNC with remote desktop (RDP) ?

Find help for Frequently Asked Questions here - please look here first before posting an already answered question.

How to install UltraVNC with remote desktop (RDP) ?

Postby redge » 2006-06-01 15:05

installing remotely via MS remote desktop - set password??
install any VNC flavor by remote desktop Terminal Service
and prevent VNC default password not set or/and no responsive of winvnc service or uvnc_service

Follow these instructions exactly for uvnc 104

1. (I assume UltraVNC is already installed)
2. Stop UltraVNC Service, (administrator privilege required)
(make sure no winvnc and no uvnc_service is running via task manager)

3. Run UltraVNC in USER mode (i.e. by doubleclicking winvnc.exe)
You should see the tray icon.

4. If you right click on the icon and click "Admin Properties" you can enter your password and options etc and check the box "Accept connections" etc. as you prefer

6. Enter your password, ports, etc. as you prefer... OK

7. Close VNC Connections the user-mode WinVNC
(nicely--using the tray icon).

8. Start uvnc_service Service or restart computer if you don't have right access.


ultrarich wrote:I was having this same problem. I have NOT found a complete solution, however I have found a workaround that allows you to get the service up and running.

Follow these instructions exactly:
1. (I assume UltraVNC is already installed)
2. Stop UltraVNC Service
(make sure no instance is running via task manager)

3. Run UltraVNC in USER mode (i.e. by doubleclicking winvnc.exe)
You should see the tray icon.

4. If you right click on the icon and click "Admin Properties" you can enter your password and options etc and check the box "Accept connections" etc. as you prefer. However this is all ONLY for the CURRENT USER.

5. Now click the link to "Show Default Settings"
6. Enter your password, ports, etc. as you prefer. , this is REQUIRED and is for the LOCAL SERVICE

7. Close the user-mode WinVNC (nicely--using the tray icon).
8. Start WinVNC Service

You still cannot see the tray icon or set default settings etc. while it is running, but you SHOULD be able to connect to it remotely and do what you need.




pmdci wrote:1. I did a RDP connection to my server (which is HEADLESS)

2. I installed ultravnc. At this point I was having all the problems as everybody else

3. With registry editor, I browsed to HKEY_LOCAL_HACHINE\SOFTWARE and then created some the"ORL\WinVNC3\Default" keys (which are case-sensitive and without quotes):
a) created a key named ORL
b) under ORL I created another key called WinVNC3
c) under WinVNC3 I created on last key called Default

4. I then proceeded to install VNC as a service through the start menu, and nothing else (don't fiddle with any more ultraVNC icons for the moment).

5. Download the vncpwd application which you can find at http://www.sysworksoft.net/products/vncpwd.html and unpack it somewhere you can use (or you might just keep it somewhere like c:\windows\system32

6. run vncpwd from the command prompt as follows:
vncpwd /v:<password>
(where <password> is ther password of your choise

7. Restart the computer. This is very, VERY important. Restarding the service didn't worked for me and I was still getting the "no password" error. Only after I restarted the server that things worked out.


rmoller wrote:DO NOT connect to the local console with RDP/TS! That is, DO NOT use mstsc /CONSOLE /V:server ! VNC is not compatible with servers who "have suffered" RDP/TS connect to local console.

I have no problems installing Ultravnc as service (and mirror driver) from remote desktop/TS - if I first populate HKEY_LOCAL_MACHINE/Software/ORL/WinVNC3 with the Password entry copied from another installation.

I have first installed Ultravnc as service on my local PC and configured default password. Then I export HKEY_LOCAL_MACHINE/Software/ORL/WinVNC3 from regedit to a flat file. This file can be copied to the RDP/TS server and imported with regedit. Once this is done, UltraVNC can be installed normally as service, and it will be ready to connect to with VNCviewer and the same default password as the original local PC. Then you can change password/auth.


jstack wrote:create the registry value AuthRequired under HKEY_LOCAL_MACHINE\Software\ORL\WinVNC3 and set it to 0 (a DWORD value). That enabled "passwordless" VNC access, which isn't that bad in my case since I limited it to loopback only anyway (and I can keep the VNC service stopped when not needed). Also, MSLogon seems to work when I enabled that in the registry as well.


adrenalynn wrote:Immediately log in with VNC and start it as a service.

Now since VNC is hooking video as if we were sitting in front of a console rather than RDP's session stuff, we can attach to the newly started vnc service. Go to start->program files->Ultra VNC->Ultra VNC Server [folder]->Show Default Settings (Assuming everything is in the default places/names at least...)

Now set your password. Do a save and get outta there. Exit VNC client locally, and reconnect - now it prompts for password. Remove the authrequired key.
Last edited by redge on 2008-06-22 17:19, edited 14 times in total.
UltraVNC 1.0.9.6.1 (built 20110518)
OS Win: xp home + vista business + 7 home
only experienced user, not developer
redge
Super-Mod
Super-Mod
 
Posts: 6815
Joined: 2004-07-03 17:05
Location: Switzerland - Geneva

Return to FAQ

Who is online

Users browsing this forum: No registered users and 2 guests