Remote connection UltraVNC always aborts 1s after connection

Here you will find help for frequently asked questions as well as for your specific question.

Remote connection UltraVNC always aborts 1s after connection

Postby keith » 2019-01-15 10:38

Remote connection UltraVNC always aborts 1s after connection.
In the application event logs we found the following error:

Faulting application name: WinVNC.exe, version: 1.2.1.7, time stamp: 0x5a566ca1
Faulting module name: WinVNC.exe, version: 1.2.1.7, time stamp: 0x5a566ca1
Exception code: 0xc0000005
Fault offset: 0x00000000000cf93b
Faulting process id: 0x2c28
Faulting application start time: 0x01d4727af82db6f6

The workstations is set up with 3 displays:
Display 1:
Connected to adapter: Barco MXRT 2600 (WDDM) (\Registry\Machine\System\CurrentControlSet\Control\Video\{5D142E2C-5A29-4C90-8569-58E4749E5666}\0000)
Primary Display Device: NO
Monitor Model Name: MDNC-2221
Color Type: Color
Driver: CDD
Resolution: 1600x1200
Color Depth: 32-bit color
Refresh Rate: 60 Hz
Displayed Format: 30 bits

Current Timing Mode:
1600 X 1200 @ 60 Hz
Pixel clock: 130.250 MHz
Horiz active: 1600
Horiz blank total: 160
Horiz front porch: 48
Horiz sync time: 32
Vert active: 1200
Vert blank total: 35
Vert front porch: 3
Vert sync time: 4
Resulting hfreq: 74.01 kHz
Resulting vfreq: 59.93 Hz
Color depth: 10 10 10
Flags: 0x4

Display 2:
Connected to adapter: Barco MXRT 2600 (WDDM) (\Registry\Machine\System\CurrentControlSet\Control\Video\{CDFA4AB5-4619-4487-A894-6DEC7B9AEFE6}\0000)
Primary Display Device: NO
Monitor Model Name: MDNC-2221
Color Type: Color
Driver: CDD
Resolution: 1600x1200
Color Depth: 32-bit color
Refresh Rate: 60 Hz
Displayed Format: 30 bits

Current Timing Mode:
1600 X 1200 @ 60 Hz
Pixel clock: 130.250 MHz
Horiz active: 1600
Horiz blank total: 160
Horiz front porch: 48
Horiz sync time: 32
Vert active: 1200
Vert blank total: 35
Vert front porch: 3
Vert sync time: 4
Resulting hfreq: 74.01 kHz
Resulting vfreq: 59.93 Hz
Color depth: 10 10 10
Flags: 0x4

Display 3:

Connected to adapter: Barco MXRT 2600 (WDDM) (\Registry\Machine\System\CurrentControlSet\Control\Video\{5D142E2C-5A29-4C90-8569-58E4749E5666}\0001)
Primary Display Device: YES
Monitor Model Name: E223W
Color Type: unknown color type
Driver: CDD
Resolution: 1680x1050
Color Depth: 32-bit color
Refresh Rate: 60 Hz
Displayed Format: 24 bits

Current Timing Mode:
1680 X 1050 @ 60 Hz
Pixel clock: 146.250 MHz
Horiz active: 1680
Horiz blank total: 560
Horiz front porch: 104
Horiz sync time: 176
Vert active: 1050
Vert blank total: 39
Vert front porch: 3
Vert sync time: 6
Resulting hfreq: 65.30 kHz
Resulting vfreq: 59.96 Hz
Color depth: 8 8 8
Flags: 0x4

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Ultravnc2_is1]
"Inno Setup: Setup Version"="5.5.9 (a)"
"Inno Setup: App Path"="C:\\Program Files\\UltraVNC"
"InstallLocation"="C:\\Program Files\\UltraVNC\\"
"Inno Setup: Icon Group"="UltraVNC"
"Inno Setup: User"="lokadmin"
"Inno Setup: Setup Type"="custom"
"Inno Setup: Selected Components"="ultravnc_server_s"
"Inno Setup: Deselected Components"="ultravnc_server,ultravnc_viewer,ultravnc_repeater,ultravnc_upgrade"
"Inno Setup: Selected Tasks"="installservice,startservice"
"Inno Setup: Deselected Tasks"="desktopicon"
"Inno Setup: Language"="de"
"DisplayName"="UltraVnc"
"UninstallString"="\"C:\\Program Files\\UltraVNC\\unins000.exe\""
"QuietUninstallString"="\"C:\\Program Files\\UltraVNC\\unins000.exe\" /SILENT"
"DisplayVersion"="1.2.1.7"
"Publisher"="uvnc bvba"
"URLInfoAbout"="http://www.uvnc.com"
"HelpLink"="http://forum.ultravnc.info"
"URLUpdateInfo"="http://www.uvnc.com"
"NoModify"=dword:00000001
"NoRepair"=dword:00000001
"InstallDate"="20181008"
"MajorVersion"=dword:00000001
"MinorVersion"=dword:00000002
"VersionMajor"=dword:00000001
"VersionMinor"=dword:00000002
"EstimatedSize"=dword:0000263a
"SystemComponent"=dword:00000001
"sEstimatedSize2"=dword:00001f8c

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\VivantesPackages UltraVNC.org UltraVNC Server 1.2.1.7]
"DisplayName"="VivantesPackages UltraVNC.org UltraVNC Server 1.2.1.7"
"DisplayIcon"="C:\\Program Files\\VivantesPackages\\UltraVNC.org\\UltraVNC Server\\1.2.1.7\\Install\\Setup.ico,0"
"Publisher"="UltraVNC.org"
"DisplayVersion"="1.2.1.7"
"PackageGUID"=""
"UninstallString"="\"C:\\Program Files\\Common Files\\Setup64\\Setup.exe\" \"C:\\Program Files\\VivantesPackages\\UltraVNC.org\\UltraVNC Server\\1.2.1.7\\Install\\Setup.inf\" /X4"
"MachineKeyName"="VivantesPackages\\UltraVNC.org\\UltraVNC Server\\1.2.1.7"

Updating to the latest version of Ultra VNC does not solve the issue, connecting different spam monitor the connection works as normal.
What troubleshooting steps would you advice?
keith
 
Posts: 2
Joined: 2019-01-14 10:36

Re: Remote connection UltraVNC always aborts 1s after connec

Postby Rudi De Vos » 2019-01-15 20:10

Need more info
OS vnc server ?
Capture method ? ddengine / mirror / system
ultravnc.ini ( erase the passwd )
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5933
Joined: 2004-04-23 10:21

Re: Remote connection UltraVNC always aborts 1s after connec

Postby keith » 2019-01-22 08:48

version of VNC-server is 1.2.1.7.
Where can I find the capture method? ddengine / mirror / system
untravnc.ini settings:
[ultravnc]
passwd=
passwd2=
[admin]
UseRegistry=0
MSLogonRequired=1
NewMSLogon=1
DebugMode=0
Avilog=0
path=%programfiles%\UltraVNC
service_commandline=
accept_reject_mesg=Das Fernwartungsprogramm WinVNC empfaengt eine eingehende Verbindung von
DebugLevel=8
DisableTrayIcon=0
rdpmode=0
LoopbackOnly=0
UseDSMPlugin=0
AllowLoopback=0
AuthRequired=1
ConnectPriority=1
DSMPlugin=
AuthHosts=
DSMPluginConfig=SecureVNC;0;0x00104001;
AllowShutdown=0
AllowProperties=0
AllowEditClients=0
FileTransferEnabled=1
FTUserImpersonation=1
BlankMonitorEnabled=0
BlankInputsOnly=0
DefaultScale=1
CaptureAlphaBlending=1
BlackAlphaBlending=0
primary=1
secondary=1
SocketConnect=1
HTTPConnect=1
XDMCPConnect=0
AutoPortSelect=1
PortNumber=0
HTTPPortNumber=0
IdleTimeout=0
IdleInputTimeout=0
RemoveWallpaper=1
RemoveAero=1
QuerySetting=4
QueryTimeout=30
QueryAccept=2
QueryIfNoLogon=0
InputsEnabled=1
LockSetting=0
LocalInputsDisabled=0
EnableJapInput=0
FileTransferTimeout=30
kickrdp=0
clearconsole=0
[admin_auth]
group1=
group2=
group3=
locdom1=0
locdom2=0
locdom3=0
[poll]
TurboMode=1
PollUnderCursor=0
PollForeground=1
PollFullScreen=1
OnlyPollConsole=0
OnlyPollOnEvent=0
MaxCpu=80
EnableDriver=1
EnableHook=1
EnableVirtual=0
SingleWindow=0
SingleWindowName=
[UltraVNC]
passwd=
passwd2=
keith
 
Posts: 2
Joined: 2019-01-14 10:36

Re: Remote connection UltraVNC always aborts 1s after connec

Postby Rudi De Vos » 2019-01-22 21:37

[poll]
EnableDriver=1 (mirror driver < win7, ddengine > win7)
EnableHook=1 (system)
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 5933
Joined: 2004-04-23 10:21


Return to General help

Who is online

Users browsing this forum: No registered users and 4 guests