The Server closes the connection (with Repeater)

New to UltraVNC? Your questions are welcome in this subforum. :surprise:

The Server closes the connection (with Repeater)

Postby WhiteTiger » 2019-04-23 16:26

I know UltraVNC, but it's the first time I use the repeater.
To do this test I used 4 PCs.
1) My PC (Linux Ubuntu), on the Internet, using Remmina as a viewer.
2) A Win 10 PC (192.168.111.102), in a network behind a firewall, as a VNC-Server
3) A Win 2003 Server (192.168.111.9), as a repeater, on the same network.
4) An Ubuntu PC, in the same network, with Remmina to do internal tests.

The router has un static IP-Public-Address.
I can't use port 5900, because there are already those using it and I don't want to create confusion.

So:
I configured VNCServer with port 5500.

I configured the Repeater in this manner:
  • Mode = I
  • Listen Port Viewer 5909
  • Listen Port Server 5500
  • Only allow connection to: 192.168.111.102:5500

In the router I configurated a Port Forwarding 5909 to 192.168.111.9
From my PC, in Remmina I call IP-Public-Address:5909, but I get an error of "connection closed by the server".
So,
From the Internal PC Linux I try Remmina to 192.168.111.102:5500 = OK
From the WinSrv2003 I try VNCViewer to 192.168.111.102:5500 = OK
From My PC (in Linux) I try telnet IP-Public-Address 5909 = OK.

Where am I doing wrong?
WhiteTiger
 
Posts: 1
Joined: 2019-04-23 03:38

Return to Beginner questions

Who is online

Users browsing this forum: No registered users and 1 guest