Repeater version 1.0 responds differently

Repeater version 1.0 responds differently

Postby martinbeek » 2007-07-02 20:55

We use ultravnc repeater (w. pchelpware) here at school. It works OK, but behaves differntly from the previous version.

First, clients could connect before admin connects; now, admin needs to be connected first. This is a real pain in the ... with 100+ impatient users!

I would like to know, where in the settings or in the sourcecode i can alter this, so it behaves again as before.

Thanks for your input.


Martin Beck
Last edited by martinbeek on 2009-05-31 09:13, edited 3 times in total.
martinbeek
 
Posts: 3
Joined: 2007-07-02 20:40

Re: Repeater version 1.0 responds differently

Postby redge » 2008-02-14 23:47

update your repeater to 1.2.2.2 and your pchelpware to 1.0.1
Compatibility of PcHelpWare Repeater with UltraVNC/SC
UltraVNC 1.0.9.6.1 (built 20110518)
OS Win: xp home + vista business + 7 home
only experienced user, not developer
redge
Super-Mod
Super-Mod
 
Posts: 6815
Joined: 2004-07-03 17:05
Location: Switzerland - Geneva

Re: Repeater version 1.0 responds differently

Postby redge » 2008-07-12 10:01

*repeater: found bug that required server to be connected first.
Now you can connect server or viewer first

http://sc.uvnc.com/Update_10July.zip
UltraVNC 1.0.9.6.1 (built 20110518)
OS Win: xp home + vista business + 7 home
only experienced user, not developer
redge
Super-Mod
Super-Mod
 
Posts: 6815
Joined: 2004-07-03 17:05
Location: Switzerland - Geneva

Re: Repeater version 1.0 responds differently

Postby jksmurf » 2008-07-25 02:46

redge,

I have been through a LOT of posts on this, and I am still confused. There's a repeater.exe and a distributor.exe
It "seems", although they look very much alike, that:

a. repeater.exe is for connecting using UVNC
b. distributor.exe is for connecting using PVHW
(although for simplicity lets say distributor.exe also works with UVNC for some modes)

Now, the file in your last post with http://sc.uvnc.com/Update_10July.zip contains distributor.exe, whereas in the post before contains repeater.exe.

If I only ever use UVNC, can I assume that I only need the latest repeater i.e. repeater 1.2.2.2, because your post suggets that distributor.exe is an update to repeater.exe :o ???

ta,
k.
jksmurf
20
20
 
Posts: 56
Joined: 2006-05-24 02:30

Re: Repeater version 1.0 responds differently

Postby subnet99 » 2009-02-05 22:25

Are there any current download links available for repeater v1.2.2.2? Is 1.2.2.2 the best/most current version for uvnc server and viewer use? Also, in the distributer.exe version I see a mode for proxy 443 is this only implemented for PcHelpWare? I would like to use a mode two type of setup using one common port (80 or 443) to avoid being blocked by restrictive corporate firewalls... i.e. sc uses port 443 and viewer uses 443 both with dsm plugin for encryption but I can always just open two ports on the repeater but prefer to use just one.

Thanks for any help/replies,

Tim
subnet99
 
Posts: 3
Joined: 2009-02-05 21:21

Re: Repeater version 1.0 responds differently

Postby YY » 2009-02-06 08:23

subnet99 wrote:in the distributer.exe version I see a mode for proxy 443 is this only implemented for PcHelpWare? I would like to use a mode two type of setup using one common port (80 or 443) to avoid being blocked by restrictive corporate firewalls... i.e. sc uses port 443 and viewer uses 443 both with dsm plugin for encryption but I can always just open two ports on the repeater but prefer to use just one.

This only supports the PcHelpWare, which supposed for the server pc running under proxy environment, and is allowed to use https.

SC doesn't able to use this feature.
YY
200
200
 
Posts: 996
Joined: 2006-11-13 15:11

Re: Repeater version 1.0 responds differently

Postby subnet99 » 2009-02-06 13:57

YY wrote:This only supports the PcHelpWare, which supposed for the server pc running under proxy environment, and is allowed to use https.

SC doesn't able to use this feature.


Thanks for the info.., Do you know where I can download v.1.2.2.2? I only find dead links to it.
subnet99
 
Posts: 3
Joined: 2009-02-05 21:21

Re: Repeater version 1.0 responds differently

Postby YY » 2009-02-06 14:19

I don't know! Not available anywhere!

Without any announcement, UVNC remove all the original repeater package. The one now on the download page is a new CMD mode application -- yet without any instruction of its usage.
SO FAR NOBODY TELLING ANYTHING ABOUT THIS. WHAT IS GOING ON !!!!?????.

So the only workable version is the one referred by redge:
http://sc.uvnc.com/Update_10July.zip
which is a PcHelpWare repeater, but workable for UVNC & SC too.
Or unless you download the old package from UVNC 1.0.2, or PcHelpWare 1.0
YY
200
200
 
Posts: 996
Joined: 2006-11-13 15:11

Re: Repeater version 1.0 responds differently

Postby cristobalmiguelo » 2009-04-23 20:52

redge wrote:update your repeater to 1.2.2.2 and your pchelpware to 1.0.1
Compatibility of PcHelpWare Repeater with UltraVNC/SC


Hi,

How can I update the software you mention? The website only has pchelpware 1.0.0 available. Can you help me download the newer versions? I hope there's an official download from the uvnc.com website.

Best,
Cristobal
cristobalmiguelo
 
Posts: 2
Joined: 2009-04-12 18:26

Re: Repeater version 1.0 responds differently

Postby redge » 2009-04-23 21:30

update pchelpware 1.0.1
http://www.uvnc.com/download/SCDLL.zip

repeater 1.2.2.2 url is lost and unofficial sorry.
UltraVNC 1.0.9.6.1 (built 20110518)
OS Win: xp home + vista business + 7 home
only experienced user, not developer
redge
Super-Mod
Super-Mod
 
Posts: 6815
Joined: 2004-07-03 17:05
Location: Switzerland - Geneva


Return to PcHelpWare

Who is online

Users browsing this forum: No registered users and 1 guest