"Zero Configuration" PcHelpWare_viewer for TESTING ONLY"

"Zero Configuration" PcHelpWare_viewer for TESTI

Postby mattice06082 » 2007-03-24 02:47

I've tried to make this easy as possible. PcHelpWare is a very powerful tool, which is highly customizable. However, for those of you who just want to help mom and don't want to mess around with port forwarding or setting up a repeater I've created a Zero Configuration (or at least as close as I could get to zero configuration) setup of the PcHelpWare_viewer:

Image

Notes:
1) Password should be 7 characters or less
2) ID should be something unique to you. You will have trouble if someone else is trying to use the repeater01.ultravnc.info repeater with the same ID so don't use 1 or 1234 or 8363 that I show in this example.

a) Click Save. After saving, a PHW-file will show up in the list box called Repeater.phw.
b) Click Create Server. Select No to Does the user need to enter the ID?. Select No to Does the user need to enter the password?. This will create a PcHelpWare_server.exe in the PcHelpWare\myservers\Repeater directory. This is the file you need to get to those you wish to support. The best way to transfer the file is to host it for downloads. I don't have my own website so I've hosted mine using a free MediaMax account.

When mom calls because she's got a PC problem,
a) Open PcHelpWare_viewer, select Repeater.phw and click Start.
b) Mom needs to download your hosted PcHelpWare_server and run it. She'll then simply need to click Connect.

Notes:
1) Security software may notify you and your mom that your respective programs are trying access the internet. You need to allow the connection.
2) There seems to be some bugs associated with the repeater that require it to be occasionally restarted. In the event that there appears to be a problem with the repeater, please post to Other Repeaters besides uvnc.com (3 so Far) so it can be restarted.


Hope this helps.
Last edited by mattice06082 on 2009-05-31 09:17, edited 2 times in total.
mattice06082
Former moderator
Former moderator
 
Posts: 607
Joined: 2006-11-30 00:41
Location: Connecticut, USA

Re: "Zero Configuration" PcHelpWare_viewer Setup

Postby melanie » 2007-04-29 21:04

I have set up the zero configuration.
When I start the viewer I get
Start
Using Repeater
repeater01.ultravnc.info
ID:XXXX
Start encryption
Waiting for server

Then when "connect" using the server it tells me the existing connection was closed by the remote host.

(I did click test on the repeater area when I set this up and it said the viewer port and server port were both ok.)

If you have any ideas on what I can do, please let me know. Thank you!
melanie
 
Posts: 4
Joined: 2007-04-29 20:55

Re: "Zero Configuration" PcHelpWare_viewer Setup

Postby bevtech » 2007-04-29 22:39

Try again. It is possible the repeater was stuck i restarted it..:)
Bevtech

Windows XP Home, Pro SP2, Windows 2003 SBS server SP2(EN), Windows Media Center Editon 2005,Windows Vista Home Prem.,Fedora Core 6,Win9X, PChelpware Rel 1.0,
UVNC V 1.0.8.2

User not developer..;)
bevtech
Super-Mod
Super-Mod
 
Posts: 2191
Joined: 2005-08-03 14:07
Location: Pennsylvania, United States

Re: "Zero Configuration" PcHelpWare_viewer Setup

Postby melanie » 2007-04-29 22:48

Thank you.

I connected using the server and viewer on the same pc.

When I take the server file to another pc it tells me
"failed to connect"
The requested name is valid and was found in the database.
"Init Network failed."

Any ideas?
Thank you so much. I greatly appreciate the assistance.
Melanie
melanie
 
Posts: 4
Joined: 2007-04-29 20:55

Re: "Zero Configuration" PcHelpWare_viewer Setup

Postby melanie » 2007-04-29 22:49

I messed up.... Figured it out.

Thank you.
m
melanie
 
Posts: 4
Joined: 2007-04-29 20:55

Re: "Zero Configuration" PcHelpWare_viewer Setup

Postby photoman » 2007-07-05 01:21

Melanie

Would you care to elaborate on your solution, as I have had the same problem. I used the server app successfully on a home PC (easy to test), but when I try it on my networked PC in work, I get the same messages you were getting.

Start
Using Repeater
repeater name here
ID:xxxxx
Failed to connect
The requested name is valid and was found in the database
Init Network Failed

I know it's not the repeater causing the problem, because I connected to it before and after trying the PC.

Our PCs are locked down quite a bit and access is quite restricted. Would a restriction on usuable ports be causing this? It's just that we have customers who will be behind firewalls and will have similarly locked down PCs, and it would be nice to know if we face the same issues trying to connect to them.
photoman
8
8
 
Posts: 29
Joined: 2007-06-03 11:52
Location: Paraparaumu, Wellington, NZ

Re: "Zero Configuration" PcHelpWare_viewer Setup

Postby melanie » 2007-07-06 20:35

For me, I had just messed up on the configuration..... just a typo or something obvious on my part.

For me, when it didn't work it was the repeater needing to be restarted.

It's been awhile since I've goofed around with it, but I'll try it again and see what I get.
melanie
 
Posts: 4
Joined: 2007-04-29 20:55

Re: "Zero Configuration" PcHelpWare_viewer Setup

Postby bevtech » 2007-09-02 17:04

UPDATE!!!!!

The repeater has been moved and now supports ssl...;) The Dyndns may work but is known to be buggy...


I moved it to another server the has access to the ssl port so hopefully this will help some users out!!!
Bevtech

Windows XP Home, Pro SP2, Windows 2003 SBS server SP2(EN), Windows Media Center Editon 2005,Windows Vista Home Prem.,Fedora Core 6,Win9X, PChelpware Rel 1.0,
UVNC V 1.0.8.2

User not developer..;)
bevtech
Super-Mod
Super-Mod
 
Posts: 2191
Joined: 2005-08-03 14:07
Location: Pennsylvania, United States

Re: "Zero Configuration" PcHelpWare_viewer Setup

Postby marky_mark896 » 2007-09-27 23:07

Hi,

I followed the instructions above, but when I try to make the PcHelpWare_server.exe file, I hit the create server button, it asks me the questions in the intructions, and I answer them as the instructions state. After that, error messages pop up saying:

"cannot copy file: cannot read from the source file or disk."

It does this two times during the creation, then asks if I want to replace helpdesk.txt. Any ideas what I'm doing wrong?

Thanks,
Mark
marky_mark896
 
Posts: 1
Joined: 2007-09-27 22:58

Re: "Zero Configuration" PcHelpWare_viewer Setup

Postby bevtech » 2007-09-28 02:36

sounds like your pchelpware download is damaged did you redownload it??
Bevtech

Windows XP Home, Pro SP2, Windows 2003 SBS server SP2(EN), Windows Media Center Editon 2005,Windows Vista Home Prem.,Fedora Core 6,Win9X, PChelpware Rel 1.0,
UVNC V 1.0.8.2

User not developer..;)
bevtech
Super-Mod
Super-Mod
 
Posts: 2191
Joined: 2005-08-03 14:07
Location: Pennsylvania, United States

Re: "Zero Configuration" PcHelpWare_viewer Setup

Postby redge » 2007-10-03 18:49

"cannot copy file: cannot read from the source file or disk."

do you have your files on a shared folder on the network
UltraVNC 1.0.9.6.1 (built 20110518)
OS Win: xp home + vista business + 7 home
only experienced user, not developer
redge
Super-Mod
Super-Mod
 
Posts: 6815
Joined: 2004-07-03 17:05
Location: Switzerland - Geneva

Re: "Zero Configuration" PcHelpWare_viewer Setup

Postby bevtech » 2007-11-08 02:26

The repeater might be shut down because of abuse..It was only for testing purposes. I do not have the bandwith to run many people at once. So if the uvnc users want to use it they must only use it for testing only.. I am hoping more users will volunteer their connections for other zero configuration repeaters....:)
Last edited by bevtech on 2007-11-08 02:32, edited 1 time in total.
Bevtech

Windows XP Home, Pro SP2, Windows 2003 SBS server SP2(EN), Windows Media Center Editon 2005,Windows Vista Home Prem.,Fedora Core 6,Win9X, PChelpware Rel 1.0,
UVNC V 1.0.8.2

User not developer..;)
bevtech
Super-Mod
Super-Mod
 
Posts: 2191
Joined: 2005-08-03 14:07
Location: Pennsylvania, United States

Re: "Zero Configuration" PcHelpWare_viewer for T

Postby Scotthaslinger » 2007-11-22 23:51

Thank you all for your contributions to this proggy, I only have one issue
Using the repeater as described works fine on my test computers but
when I download it from my website XP and Vista try to open the server
program as a dos app and says cannot open in dos. any ideas.

Thanks,
Scott.
Scotthaslinger
 
Posts: 1
Joined: 2007-11-22 23:47

Re: "Zero Configuration" PcHelpWare_viewer for T

Postby redge » 2007-11-23 06:12

limited user account or not default c:\windows os folder ?
UltraVNC 1.0.9.6.1 (built 20110518)
OS Win: xp home + vista business + 7 home
only experienced user, not developer
redge
Super-Mod
Super-Mod
 
Posts: 6815
Joined: 2004-07-03 17:05
Location: Switzerland - Geneva

Re: "Zero Configuration" PcHelpWare_viewer for T

Postby Robotuner » 2007-12-03 00:14

Hi: I finally got your zero configuration to work with your test repeater site. Now I am trying to figure out what I need to do to use my own computer for a repeater. What exactly is the configuration for the computer? Can I use my webserver? Is the only requirement that I open my firewall ports 5901 and 5500 for incoming and outgoing traffic?

Thanks.
Robotuner
 
Posts: 3
Joined: 2007-12-02 23:33

Re: "Zero Configuration" PcHelpWare_viewer for T

Postby bevtech » 2007-12-03 02:21

need to have allthe above ports plus 443 if you want to use behind proxy.. Seems to work best if it has it own ip address to use..:)
Bevtech

Windows XP Home, Pro SP2, Windows 2003 SBS server SP2(EN), Windows Media Center Editon 2005,Windows Vista Home Prem.,Fedora Core 6,Win9X, PChelpware Rel 1.0,
UVNC V 1.0.8.2

User not developer..;)
bevtech
Super-Mod
Super-Mod
 
Posts: 2191
Joined: 2005-08-03 14:07
Location: Pennsylvania, United States

Re: "Zero Configuration" PcHelpWare_viewer for T

Postby Robotuner » 2007-12-03 02:31

Bevtech, thanks for the quick response. I'm not getting it to work, . . . yet, but it occurs to me that I might not understand something. My IIS server is also behind a router. It's internal ip is 192.168.112.2, so there isn't direct access to the real ip at the router. Is that the problem?

Thanks.
Robotuner
 
Posts: 3
Joined: 2007-12-02 23:33

Re: "Zero Configuration" PcHelpWare_viewer for T

Postby bevtech » 2007-12-03 13:07

yup. That would be the issue.. Need to setup port forwarding or use a repeater on the ISA server,,:)
Bevtech

Windows XP Home, Pro SP2, Windows 2003 SBS server SP2(EN), Windows Media Center Editon 2005,Windows Vista Home Prem.,Fedora Core 6,Win9X, PChelpware Rel 1.0,
UVNC V 1.0.8.2

User not developer..;)
bevtech
Super-Mod
Super-Mod
 
Posts: 2191
Joined: 2005-08-03 14:07
Location: Pennsylvania, United States

Re: "Zero Configuration" PcHelpWare_viewer for T

Postby Robotuner » 2007-12-07 17:43

Got it to work with my server, since I don't have a proxy server I did not set up port 443. Yesterday, someone tried to connect and failed. I'm thinking that he had a proxy server on his end. So, does port 443 need to be opened on my firewall so that someone elses proxy can access my repeater? Does the port also need to be forwarded?

Thanks.
Robotuner
 
Posts: 3
Joined: 2007-12-02 23:33

Re: "Zero Configuration" PcHelpWare_viewer for T

Postby bevtech » 2007-12-09 20:59

Port 443 is needed to be open on the repeater for proxy passt through..:)
Last edited by bevtech on 2007-12-09 20:59, edited 1 time in total.
Bevtech

Windows XP Home, Pro SP2, Windows 2003 SBS server SP2(EN), Windows Media Center Editon 2005,Windows Vista Home Prem.,Fedora Core 6,Win9X, PChelpware Rel 1.0,
UVNC V 1.0.8.2

User not developer..;)
bevtech
Super-Mod
Super-Mod
 
Posts: 2191
Joined: 2005-08-03 14:07
Location: Pennsylvania, United States

Re: "Zero Configuration" PcHelpWare_viewer for T

Postby Regman » 2007-12-18 19:45

I use the repeater to test. While in connection settings I choose via repeater, enter alias of test 105 no password, id of 100, my host repeater ip , listen port viewer and server. UPnp auto.
Test, both ports say ok.
Create server
move the file to another pc in the same lan segment.
Try to connect all seem to go well until I get waiting for viewer.
I never get a prompt to accept connection or anything.
I have rebooted and restarted the repeater service. No difference.

Firewall, A/V, router have the settings in their exception lists.

Any Ideas

Thanks
Regman
 
Posts: 1
Joined: 2007-12-18 06:00

Re: "Zero Configuration" PcHelpWare_viewer for T

Postby redge » 2007-12-18 20:16

you must have pchelpware_viewer started before the pchelpware_server.
UltraVNC 1.0.9.6.1 (built 20110518)
OS Win: xp home + vista business + 7 home
only experienced user, not developer
redge
Super-Mod
Super-Mod
 
Posts: 6815
Joined: 2004-07-03 17:05
Location: Switzerland - Geneva

Re: "Zero Configuration" PcHelpWare_viewer for T

Postby bevtech » 2008-09-17 20:20

power was out since sunday finally got back up on weds GMT -5 16:20
Bevtech

Windows XP Home, Pro SP2, Windows 2003 SBS server SP2(EN), Windows Media Center Editon 2005,Windows Vista Home Prem.,Fedora Core 6,Win9X, PChelpware Rel 1.0,
UVNC V 1.0.8.2

User not developer..;)
bevtech
Super-Mod
Super-Mod
 
Posts: 2191
Joined: 2005-08-03 14:07
Location: Pennsylvania, United States


Return to PcHelpWare

Who is online

Users browsing this forum: No registered users and 2 guests

cron