UltraVNC Reverse-Connection doesn-t work

Here you will find help for frequently asked questions as well as for your specific question.

UltraVNC Reverse-Connection doesn-t work

Postby sistemas@nnttr.com » 2020-11-10 09:04

Hi,
We are using UltraVNC 1.2.1.6 and after updating to 1.2.2.3 "Reverse Connect" does not work. I have updated to latest version also, but it seems this feature does not work since 1.2.2.3

Any help would be very appreciated
best regards,
JJ.-
sistemas@nnttr.com
 
Posts: 6
Joined: 2020-11-10 08:59

Re: UltraVNC Reverse-Connection doesn-t work

Postby Rudi De Vos » 2020-11-11 16:22

Doesn't work ?
no connection, error code crash

Try first with firewalls to see if it is a firewall issue ...
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 6289
Joined: 2004-04-23 10:21

Re: UltraVNC Reverse-Connection doesn-t work

Postby sistemas@nnttr.com » 2020-11-12 09:40

We are testing in the same subnet... no firewalls. Windows Firewall disabled, Antivirus disabled...
If we uninstall verison 1.2.4.0 and then install version 1.2.1.6 on the server side, reverse conection works fine...
When installing versions above 1.2.1.6 reverse conection fails... and you can´t see any error...
sistemas@nnttr.com
 
Posts: 6
Joined: 2020-11-10 08:59

Re: UltraVNC Reverse-Connection doesn-t work

Postby sistemas@nnttr.com » 2020-12-21 10:03

We have installed the last version of UltraVNC: 1.3.2 and reverse connection still does not work...
The problem is in the file winvnc.exe; if we stop uvnc service, change this file with winvnc.exe from version 1.2.16, and start uvnc service, reverse connection works!

Any help would be very appreciated
Best regards,
JJ.-
sistemas@nnttr.com
 
Posts: 6
Joined: 2020-11-10 08:59

Re: UltraVNC Reverse-Connection doesn-t work

Postby Rudi De Vos » 2020-12-21 11:23

Retesten and invers is still working
1) run viewer is lmisten mode
2) server: add client

testing with server and viewer on the the same pc, this should always work, it's a basic test.
Image
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 6289
Joined: 2004-04-23 10:21

Re: UltraVNC Reverse-Connection doesn-t work

Postby sistemas@nnttr.com » 2020-12-21 16:00

Hi,

many thanks for your help! I have been making diferents tests and here are the results:
We have PC1 and PC2; PC2 runs winvnc.exe as the server side, and we want to make a reverse connection to PC1
in PC1 we execute: "C:\Program Files\uvnc bvba\UltraVNC\vncviewer" -listen 5501
in PC2 we execute: C:\Program Files\uvnc bvba\UltraVNC\winvnc" -connect PC1::5501

1. When winvnc.exe runs as a service in PC2, reverse connection fails when executing winvnc -connect PC1::5501
2. If we stop the service, and we run winvnc.exe manually in PC2, then executing winvnc -connect PC1::5501 works
3. If we run winvnc.exe as a service with tray icon, if we click on tray icon and select "Add new client" and as host name we type PC1::5501, reverse connection works

It seems that there is a problem with winvnc.exe running as a service and the command "winvnc -connect"

Any idea?
Remember, with winvnc.exe v1.2.1.6, reverse connection works fine even with winvnc running as a service and using the command line...

Many thanks and best regards
JJ.-
sistemas@nnttr.com
 
Posts: 6
Joined: 2020-11-10 08:59

Re: UltraVNC Reverse-Connection doesn-t work

Postby Rudi De Vos » 2020-12-21 16:52

The injection was considered unsecure. A guest can initiate a remote connection.
This is off by default and need to be enabled in the ini.
[admin]
AllowInjection=1

If the original question included
" When winvnc.exe runs as a service in PC2, reverse connection fails when executing winvnc -connect PC1::5501"

the answer would have been faster.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 6289
Joined: 2004-04-23 10:21

Re: UltraVNC Reverse-Connection doesn-t work

Postby sistemas@nnttr.com » 2020-12-21 17:08

Don´t worry for the delay Rudi, it´s my fault, and the most important thing is that now is working!!!

I will deploy the new ultravnc.ini to all PCs in our domain.

One last question: I have checked and this key "AllowInjection" does not exist in our older versions of ultravnc

Is there any problem if we deploy this new key to PCs with older versions of UltraVNC? I suppuse that the key will be ignored but I prefer to ask...

Ragards and many thanks!
JJ.-
sistemas@nnttr.com
 
Posts: 6
Joined: 2020-11-10 08:59

Re: UltraVNC Reverse-Connection doesn-t work

Postby Rudi De Vos » 2020-12-21 18:27

You can use the new ini with an old version.
unknown keys are ignored.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 6289
Joined: 2004-04-23 10:21

Re: UltraVNC Reverse-Connection doesn-t work

Postby sistemas@nnttr.com » 2020-12-22 10:50

OK. Thanks a lot for your support
Best Regards,JJ.-
sistemas@nnttr.com
 
Posts: 6
Joined: 2020-11-10 08:59

Re: UltraVNC Reverse-Connection doesn-t work

Postby dsteward » 2021-01-14 20:56

Please add this:
AllowInjection=1
to the repeater Documentation page.
dsteward
 
Posts: 5
Joined: 2012-11-06 23:59


Return to General help

Who is online

Users browsing this forum: Bing [Bot] and 22 guests