system tray icon uvnc as application but missing as service

Here you will find help for frequently asked questions as well as for your specific question.

system tray icon uvnc as application but missing as service

Postby haramo » 2021-03-13 22:14

Dear

I installed Ultra vnc 64bit 1.3.3 Dev4 at my home's laptop and works.

I now installed same on a Server (Win server 2019 standard, version 1809 ).

After starting uvnc server, In taskmanager I can see the app VNC server running with a service linked to it.

But on my home laptops I see in taskmanagement, the VNC SERVER app twice , one without a service and the other with a service. and the system tray icon text , shows that the app is running as a service.


So i started the vnc server once again on the Windows server , then the icon appears on system tray, but it's not showing that the app is running as a service (as on my home laptop), but as an aplication.

Right click the icon, gives me options : start service (must be installed first) , Uninstall service but install service and stop Service is gray as is reboot in safe mode and force reboot (unsafe).


While at my homes laptops, the stop service can be clicked on and also on the last two options (save mode and forece).

Now only issue I have is I cannot start as a service, and all is running as it should be.

I tried to search first in this forum, but could not find a solution.

Hope someone can help.
haramo
 
Posts: 7
Joined: 2012-06-28 16:39

Re: system tray icon uvnc as application but missing as ser

Postby Rudi De Vos » 2021-03-14 16:32

Does the start service ( must be installed first) doesn't work ?
The option to uninstall indicate that the service is installed.

you can start and stop the service from the commanline
install/uninstall

net start uvnc_service
net stop uvnc_service
install service
winvnc.exe -install
winvnc.exe -uninstall

You can also check the service status
Image
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 6290
Joined: 2004-04-23 10:21

Re: system tray icon uvnc as application but missing as ser

Postby haramo » 2021-03-14 17:55

Does the start service ( must be installed first) doesn't work ?

Does not work, I mean, i can click on it, but then uvnc shutsdown, I receive a useraccountmanage message to allow uvnc make changes, I confirm by yes. AFter this nothing hapens, the uvnc icon doesn't show anymore .

I cheched the service uvnc, it's up and running.

I even followed your steps in CMD but uvnc till starts only in application mode.

I have read some more articles:

Maybe this info can help: The host contains 3 VM's , I'm now connectid using microsoft RDP to one of the virtual servers. and I'm installing Uvnc on this virtual server.
I have aministrator rights.
haramo
 
Posts: 7
Joined: 2012-06-28 16:39

Re: system tray icon uvnc as application but missing as ser

Postby haramo » 2021-03-14 18:03

I found a work arround.

After reading the old articles, RDP connection could be the issue why the start service could'nt work.

it talked about changing registry... .


What I did: I logged on the RDS server, using chrome remote desktop. then I hit the start service(must be installed first), and now the icon appears back and after clicking yes on the user account manage to allow changes, I now have uvnc running as a service.

So in short, it's not possible to do a full installation with Uvnc through a RDS session.

Is this related to UVNC , some kind of security?


added: If I connect to RDS : I don't see the icon in sytem tray, I have to start uvnc again, then it's back as a application.
But taskmanager shows now exactly as on my laptops: twee uvnc processors. So I assume it will work as a service, even I don't see any icon in traysystem.

ADDED

before I only had uvnc as a application, and I setup the port forwardign and had no issue to make a connection with uvnc viewer at my home to the server.

now there are twee uvnc processes running as it should be, but It's as if the port is closed, I cannot connect.

While writing , I rebooted the RDS server. now it seems to work (chrome remote desktop open) closing the chrome remote desktop, I still can continue with the viewer.
Loging back on the RDP (microsoft), I now see the icon in system tray.
and I can simultanously connect with viewer and have this RDS session open.

ONly if I minimize the RDS session, then viewer turns black. Viewer does recover , once I maximize the RDS session window. as long the RDS window is open, it doesn't has to be the full screen, viewser keeps working.

When I log off my RDS session, Viewer still keeps connected , but I need to log in again.

I must first hit Ctrl Alt DEL , it doesnt work to do this. Send custom key, but I found the button that can do the job.

the resolution is smaller, if I connect direcly from the viewer. as if I' min a console environment.
haramo
 
Posts: 7
Joined: 2012-06-28 16:39

Re: system tray icon uvnc as application but missing as ser

Postby Rudi De Vos » 2021-03-14 19:25

If you clone a RDP session you are limited to the MS RDP implementation.
A minimize or closed rdp session doesn't have a framebuffer ( RDP disable it) -> vnc has a black.

When vnc run as service, it clone the console, not the rdp session.
If vnc run as application it clone the current session.
Rudi De Vos
Admin & Developer
Admin & Developer
 
Posts: 6290
Joined: 2004-04-23 10:21


Return to General help

Who is online

Users browsing this forum: Bing [Bot] and 24 guests