x11vnc and DSM plugins

Simple, Free, Open Source UltraVNC Wrapper Supporting Windows and Mac OSX.

x11vnc and DSM plugins

Postby supercoe » 2012-03-14 14:14

I haven't received a response from Karl Runge on this so I was hoping someone here could help me out.

Hi Karl,

I don't know if you remember me but I'm the creator of ChunkVNC and I
have a question for you about how I get the SecureVNC plugin working
with an UltraVNC server and your vnc viewer.

Everything seems to work just fine when I use the older MSRC4 plugin
other than these messages:
ultravnc_dsm_helper: encrypt - WARNING: MSRC4 mode and IGNORING random salt
ultravnc_dsm_helper: encrypt - WARNING: and initialization vector!!
ultravnc_dsm_helper: decrypt - WARNING: MSRC4 mode and IGNORING random salt
ultravnc_dsm_helper: decrypt - WARNING: and initialization vector!!

Not a big deal as my main goal is to get the software to function with
SecureVNC anyways, I just wanted to see if I could get it to work at

So here is my setup I'm having trouble with:

XP Home with a default UltraVNC server configured with the
SecureVNC plugin passphrase of "password1" and an IP of
I tested this setup with the UltraVNC viewer + SecureVNC plugin and it
works as intended.

Hackintosh Lion 1.7.2 using bins from the
ssvnc_no_windows-1.0.29.tar.gz release and an IP of

1) Start the helper.

./ultravnc_dsm_helper securevnc pw=password1 5901

Then it outputs:

ultravnc_dsm_helper: waiting for connection on port: 5901

2) Start the viewer.

./vncviewer localhost:5901 -ultradsm

Then the helper outputs:

ultravnc_dsm_helper: got connection: 5

Sadly unlike my test with the MSRC4 plugin it doesn't seem to do
anything but hang here for about a minute.

After the timeout the helper outputs:

securevnc_setup: fail read rsabuf: n=0 len=12

The UltraVNC server will say:

"Failed to connect to!"

I've also tried generating the .pkey and using
"./20120208_Viewer_ClientAuth.pkey" instead of "pw=password1" but get
the same result.

I know you're a busy guy and I apologize for asking you to do tech
support for me but I've exhausted all other means of trying to figure
this out.
If you could point me in the right direction or tell me if my syntax
is wrong I would greatly appreciate it!

Thanks, Nick
http://www.chunkvnc.com - ChunkVNC - Free PC Remote control with the Open Source UltraVNC wrapper InstantSupport!
User avatar
Posts: 1735
Joined: 2009-07-20 21:27
Location: Walker, MN

Re: x11vnc and DSM plugins

Postby rcooke » 2017-04-09 14:59

Any news on this?

I'm trying to use ssvnc with uVNC server with SecureVNCPlugin64.dsm enabled and I'm seeing the same thing.

It connects, then hangs until timeout.

The ssvnc side says:

Code: Select all
ultravnc_dsm_helper: got connection: 0
securevnc_setup: fail read rsabuf: n=0 len=12
vncviewer.x11: VNC server closed connection

2017/04/09 15:42:28 VNC Viewer exiting.

vncviewer command failed: 0

And the uVNC debug log says

Code: Select all
Sun Apr 09 10:44:57 2017
vncmenu.cpp : ############### Usernames change: old="Richard Cooke", new="Richard Cooke"
--The system cannot find the file specified.
Sun Apr 09 10:44:58 2017
vsocket.cpp : socket error 1: 10060
--A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
vncclient.cpp : Reconnect to repeater
vncserver.cpp : removing unauthorised client
vncserver.cpp : RemoveClient() done
vncclient.cpp : ~vncClient() executing...
vncclient.cpp : deleting socket
vsocket.cpp : closing socket
Sun Apr 09 10:45:02 2017
vncmenu.cpp : ############### Usernames change: old="Richard Cooke", new="Richard Cooke"
--The system cannot find the file specified.
Sun Apr 09 10:45:07 2017

This is uVNC server on Windows 7 64-bit PRO.

ssvnc version 1.0.30 on MAC OS/X 10.11.6 El Capitan
Richard Cooke
User avatar
Posts: 97
Joined: 2011-02-19 13:06
Location: Toronto, Canada

Re: x11vnc and DSM plugins

Postby mhertz » 2018-04-19 13:25

I have exact same issue, and tried troubleshoot for a month but gotten nowhere and sadly ssvnc isn't in development since 2011 :(

I love ssvnc, and have tested that most ultravnc-related still works i.e. file-transfer, chat, n/1 scalling etc, but I also cannot get encryption to work :( Granted I use ssh-tunneling instead for encryption, but just for the hell of it, also wanted to have encryption working e.g. so that I can point other linux users to ssvnc, as I don't recall seeing other linux viewers ever supporting this(ultravnc encryption).

If anyone ever have some insights on this, it would be very much appreciated!

Edit: Mailed Krunge, just like the OP also did originally. Here's hoping to get a reply this time :) (Of course I understand, and don't expect personal support for a free and abandoned project!)

Edit2: Several people have tried contacting Runge throughout the years with no contact, which is odd because he was very responsive before. Then I read this, which I really hope doesn't mean what I think it does:

"He helped us out with an x11vnc chained cert issue back in late Feb. 2010, so I can attest to him being around, and very approachable/communicative, as of 2010.

Out of curiosity, I Googled the heck out of him and it led me to property records where it looks like his wife took over ownership of record for their home in 2014. That may not mean anything, but is not necessarily a good sign, given the dearth of any other activity/results?"

Posts: 39
Joined: 2018-02-27 20:19

Return to ChunkVNC

Who is online

Users browsing this forum: No registered users and 3 guests