Server 2003 can't connect

Simple, Free, Open Source UltraVNC Wrapper Supporting Windows and Mac OSX.

Server 2003 can't connect

Postby as400jockey » 2014-01-14 20:15

I have cobbled together the InstantSupport thing and the viewer thing. I have the repeater running. I'm connecting on port 443 for the server and 35901 for the viewer. MY goal is to support customers behind firewalls that are preventing connections on 35901. I'm hoping the 443 thing will work.

It's all good running InstantSupport from Win7 (32 and 64 bit), Win8 (32 bit), XP, Vista (32), Server 2008, server 2000... but not Server 2003 (64 bit). I tried two of my own 2003 servers, and one at another company. 0 for 3 for 2k3.

When I connect with InstantSupport from Server 2003 I get a 6 digit number... in this case 466078. From the 2003 box it looks like it's connected...

At the repeater (1.0.8) I see nothing regarding that connection number. Normally, at this point I'd see a

Server added to list 466078
recv 12

But in this case I see nothing yet.

Then I try to connect with a viewer.

When I try to connect Viewer to 466078, the Viewer dialog sits at

VNC Viewer Status for ID
ID 466078
In Progress (no encryption)

Repeater window shows:

Viewer added to list 466078
ID added 466078

But viewer never connects. The log 466078.txt shows

2014/1/14 14:21:28

When I cancel the viewer connection attempt, repeater window shows

recv -1
Viewer removed from list 466078

From this point on, no more clients can connect, even from xp / 7/ 8 /etc, that had been working. I get the popup with the 6 digit number, but shortly thereafter I get

Connection to the repeater was not possible

I have to stop and restart the repeater to get new connections. Existing connections seem to stay up.

So, to summarize, this all seems to work perfectly for every Windows OS I can get my hands on, with the glaring exception of Server 2003... As soon as I try to connect from Server 2003, it gets all confuzzled and the repeater needs to be restarted.

Any thoughts??

But wait... there's MORE! Follow up - in the 10 minutes it took me to cobble this together, I suddenly found "Server added to list 466078". Huh. I had restarted the repeater in the mean time... and now it somehow connected??? WOW. I was able to connect with a viewer.

So I tried this again...

Opened a connection from 2003 server. Got number 274148. Looked good from 2003 server, but repeater said nothing, and no connection possible. Restart repeater.

Low and behold...

Server added to list 274148
recv 12

and I can connect using ChunkViewer from my Win7 desktop. Repeater shows:

accept <> connection
Writing protocol version erro
accept <> connection
Viewer added to list 274148
ID added 274148

Tinker tinker tinker... cobble cobble cobble... connection stays up just fine.

After 15 min, close out of the InstantSupport screen on the 2003 server.

Repeater says:

Server removed from list 274148
Viewer removed from list 274148

From here I was able to start an InstantServer connection from a Win7 client, connect, play, disconnect, close, etc.. All good.

Retried InstantSupport from 2003 server... repeater doesn't see the connection. wait, wait, wait... nada. Restart repeater, 2003 connection established, all good again until 2003 tries another reconnect from scratch.

So - restarting repeater while 2003 is sitting with the ChunkVNC screen already open - works fine.
Initiating a new 2003 server connection croaks distributor until it's restarted.

How weird is this???


I hope this long winded description makes sense.
Posts: 1
Joined: 2014-01-14 19:12

Return to ChunkVNC

Who is online

Users browsing this forum: No registered users and 4 guests